Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must login to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

joe993C4

Members
  • Content count

    5
  • Joined

  • Last visited

About joe993C4

  • Rank
    Member

Profile Fields

  • From
    Boca Raton FL
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    1997 C4
  1. Thanks guys for your help! Any of you in south Florida (Ft Lauderdale/Boca Raton) ? It would be nice to know some of you to get together etc.... Sent from my iPhone using Tapatalk
  2. Thanks a lot,do you have any idea where's it located ? Any way to deactivate it? Sent from my iPhone using Tapatalk
  3. Sorry about the bump post and thanks for replying,no I haven't run any diagnostic yet but I may do it today....what can possibly be the cause ? Sent from my iPhone using Tapatalk
  4. Hello guys,I just bought this 1998 993 C4 with 46000 mls,in very good conditions here in south Florida,however there's this starting problem that is getting more and more frustrating...Whenever i start the car (cold or hot) I can actually hear the fuel pump but it doesn't crank...nothing,after a while,messing with the remote control (pushing on and off) and a lot of cursing involved...then it usually starts,I bought a lovely (!) 115$ DME relay at the dealer but obviously I didn't solve the problem....it would be nice to have a good help from you before I putting it on fire! Thanks,Joe Sent from my iPhone using Tapatalk