Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)


  • Content count

  • Donations

  • Joined

  • Last visited

Community Reputation

0 Neutral

About TLO

  • Rank

Profile Fields

  • From
    Saint Charles, MO
  • Porsche Club
  • Present cars
    2011 Porsche 911 4SC
  • Future cars
  1. New information - I test drove this evening and the foot well lights ARE working, still not the glove box original halogen. I will commence testing the glove box lights using the aforementioned suggestions.
  2. Hello, I'm new the forum and I appreciate the thread. I am replacing my halogen bulbs with LEDs in my 2011 997.2 (4SC). I could not get the new/replacement LED bulb in glove box to work so re-installed the old one which didn't work either (it did before I tried to replace it with LED). The two replacement foot well LEDs worked immediately upon installation but then stopped working a couple of hours later. Now, neither of the foot well LED lights work nor the glove box light (with original halogen bulb). Loren mentions above if the foot well lights don't work either, then I may have a VES control unit problem or it needs to be re-programmed? Is this necessary given the foot well lights with new LEDs worked at first? Anyone have suggestions? Thank you, Tim

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.