Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
ct997c2s

Creaking Noise Right Front Suspension

Recommended Posts

Have and unusual issue with my 997.1S. The right front suspension makes a creaking noise only when it's driven on wet roads and over bumpy pavement. Has anyone experienced this before?

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Have and unusual issue with my 997.1S. The right front suspension makes a creaking noise only when it's driven on wet roads and over bumpy pavement. Has anyone experienced this before?

I get the same on my c4s. Also right front. I've sent it in 3 times to the Porsche dealership and they can't find anything wrong. It's really annoying!

Share this post


Link to post
Share on other sites

In most cases this is caused by a loose or broken upper strut mount.

How do you tighten the upper strut mount? If that's not the solution do you replace the mount or the whole damper?

Share this post


Link to post
Share on other sites

Maybe it is part number 10 that needs a turn.

post-13642-0-95957100-1300312535_thumb.j

Paul

Thanks for the suggestions!

Share this post


Link to post
Share on other sites
Posted (edited)

Old post BUT there was a tech bulletin about this, 4075.  The spring top is not shaped correctly and sits wrongly, contacting the spring plate and/or the stop plate (6 and /or 4).  Fix is new springs: for the coupe, C2S manual, they are 997 343 531 42 504

Edited by floatingkiwi

Share this post


Link to post
Share on other sites
26 minutes ago, floatingkiwi said:

Old post BUT there was a tech bulletin about this, 4075.  The spring top is not shaped correctly and sits wrongly, contacting the spring plate and/or the stop plate (6 and /or 4).  Fix is new springs: for the coupe, C2S manual, they are 997 343 531 42 504

 

That post is 7 years old that you responded to...

Also, the TSB 4075 for that fault also listed in the VIN of the cars involved - so hopefully they have all been fixed by now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.