Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
05PorBox

Boxster front hood latch

Recommended Posts

I have a 05 Boxster S. My battery died and I tried the fuse box jumper process and it didn't work. So I found the emergency latch cable in the driver side front wheel well and used that to open the front hood. Now my issue is I cant get the latch to latch and keep the hood secured. Also the switch inside the passenger compartment for the front hood won't open the hood. This is my first Porsche and I am not familiar with alot of Porsche tricks any ideas of what the problem may be or where to start would be great.

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

:welcomeani:

 

You likely need to make sure the emergency cable is not still pulled out. And/or a little WD-40 on the latch mechanism - then work it back and forth.

 

Share this post


Link to post
Share on other sites

In addition to the above, check the fuse ... C3 I think it is.

Share this post


Link to post
Share on other sites

I have checked and tried those suggestions and I am experiencing the same problems. Any other Idea's?

Share this post


Link to post
Share on other sites

Solenoid which actuates latch?

 

I previously mentioned that I thought the fuse was C3. You may want to verify that from the fuse chart that comes with the car.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.