Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Hey guys, my passenger side windshield wiper isn’t working on my 2004 cayenne s. Is it maybe a linkage problem? Thanks. 

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By troyporsche
      hey guys im having a some what of an issue with my c.s front wipers, they dont work. the front jets washer work so does the rear wipers. (1) i have checked all the fuses inside and in the engine bay (2) checked that the bonnet is closed cause i know it wont work if the bonnet is opened (3) using a snap on diagnostic tool i scanned the vehicle wiper module. no cummunication with the wiper ecu (4) checked the wiper motor connectors and wires theres 5 wires im getting earth and positive (5) i jumped the gun and bought a second hand wiper motor on ebay still no luck , theres possiblity that the motor i brought is faulty.
      does anybody have a wiring diagram for the wipers to the body control ecu 
      or can help me with this issue 
    • By lewisweller
      Another one to add to the list of jobs...
       
      The passenger side wiper which has a double linkage and double shaft, one of the shaft metal bush is cracked and the wiper doesn't work correctly. The shaft spins inside the wiper arm and relies on the other part of the linkage and shaft to make the passenger wiper sweep in a fashion. 
      So I'm looking and thinking about a cost effective Fix for the infrequent bit of rain we get here. 
      Few ideas:
      1. make another bush machine shop job
      2. Make a home made bush out of aluminium can, seen this done before. 
      3. Drill and tap and then screw through the arm and into the shaft to lock all components together. 
       
      Anyone had this issues and fixed it? 
      Picture won't load up ....error 200????
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.