Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Nate Ashby

The Ubiquitous Convertible Top Issues

Recommended Posts

I think I'm losing my sanity, I've spent hours on here looking at everyone's top issues and I cant seem to figure out whats going on. Here's the breakdown.

1. The hand brake lights up the dash.

2. The windows don't drop at all when I release the top. I pulled apart the top switch and cleaned it up, seems to have good contact now.

3. The windows do drop when pulling the handles.

4. The Top does not move with the button at all (Brake Light on, all the stuffs that I'm aware of)

5. The Top will move just fine when doing this override: https://www.youtube.com/watch?v=_eWY4_fSZT4

As far as I can tell, the problem was the Top Relay Module, I bought a new one for 180$, and no dice. Nothing has changed.

Are these modules at all likely to be DOA? I can't think of anything else.

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.