Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

bkbville

Members
  • Content Count

    3
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bkbville

  • Rank
    Member

Profile Fields

  • From
    new york
  • Porsche Club
    No
  • Present cars
    boxster
  • Former cars
    914
  1. I went to clean my MAF and found this in the engine bay, but couldn't figure out what it is or where it goes... Can someone enlighten me? :) Thanks
  2. This forum is terrific! I picked up a '98 a couple of months ago, and the horn did not work. I could hear the relay when I pushed the horn button - fuse was good. I replaced the horns and (as you might suspect) the horn went off the first time I hit the brakes! Good thing I had picked up the #31 o-rings at home depot already (after reading this thread) I disconnected the battery but never bothered to disconnect the air-bag - had the required access to insert the o-rings. Horn works perfect now.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.