Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

bbhelms

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bbhelms

  • Rank
    Member

Profile Fields

  • Porsche Club
    No
  • Present cars
    2001 Seal Gray C2 Cab
  1. May sound untechnical but I had this problem where you would start to go and the car would surge ahead and then jerk back almost like a bucking horse. Ended up being the springs on the throttle body and the gas pedal being weak and the cable would pull and then let some slack so your fut on the gas ended up making it go back and forth! Thanks for the info...I will have my shop check this out, along with the hydraulic slave cylinder for the clutch. Any other ideas?
  2. Help! I am having this exact problem that Bagman describes in his first paragraph. As far as his second symptom, mine isn't really grinding as much, but the shifter as gotten more loose in the past day and it doesn't shift smoothly 1-2 and 2-3. I'd like to know what the possibilities are before I take it in.... Did anyone find the outcome of Bagman's situation? THANK YOU!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.