Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Finwiz12000

Members
  • Content Count

    1
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Finwiz12000

  • Rank
    Member

Profile Fields

  • From
    United States
  • Present cars
    997 Turbo
  1. New member here. This is a great site with loads of useful information, so thank you! I recently bought my dream car, finally, a 2007 997.1 turbo with Tip with 27k. Long story short, I bought the car and had it serviced right before winter. However, after the service which included an oil change, code P0021 came up for the first time. I took it back to the dealer and they cleared the code and told me this happens at times after an oil change. I drove the car for a few more weeks until the weather changed and the CEL light never returned, until yesterday. Again, because of the weather, the car has been sitting for a few months and I just took the car out. It ran perfect all-day long. Then the very next morning, I take the car out and about 5 min into the drive the CEL light comes on with "Visit your local shop" or something to that affect. My OBD reader indicates Code: P0021 - camshaft position over-advanced bank 2. 1 - Should I clear the code and see if the code returns, or should I have someone look further into it? 2 - I was going to clear the code and see if it comes back like previously noted by the dealer but wanted to acquire some more experienced thoughts on this. Car seems to run, idle, and drive perfectly fine. Any thoughts or guidance on what to do next would be greatly appreciated! Sorry for the long post. Thanks in advance for you guidance!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.