Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

2005 Silverboxster

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About 2005 Silverboxster

  • Rank
    Member

Profile Fields

  • From
    Ontario Canada
  • Present cars
    2005 Boxster
  1. Hey All, Brand new here and curious to know if anyone can shed some light for some issues i have. I bought a 2005 Boxster this summer, 95000kms and pristine. I had a shop do an oil service on it and they mentioned that the car looked like it had never even seen rain underneath. That said i have some options that arent working and not sure if they would all be connected some how ??? My cruise control does not work ... my heated seats dont work, rear spoiler as well is not working ..... there is no power by the looks of it ... not sure if this would be a fuse that runs all these? From the condition of the car i cant imagine anything serious but i have never owned a Porsche before so i dont want to muck around too much? I have read that if the car has sat for some time with no battery it can unrecognize the features in the car and needs a reboot from the dealer? Any insight on this would be so helpful! Many Thanks Corey
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.