Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

D Banks

Contributing Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About D Banks

  • Rank
    Contributing Member

Profile Fields

  • From
    Weston, FL
  • Porsche Club
    No
  • Present cars
    1999 Porsche Boxster
  • Future cars
    N/A
  • Former cars
    Mustang
  1. Add me to the list CDR220 SN X5020366 Any help would be appreciated D.
  2. Started the car this morning and all items are working.... Must be scared of me. D.
  3. Searched the forum and didn't find this specific thread so here goes... 1999 Boxster, 57k miles, recently purchased, good history. Neither my digital nor analog speedo works, and the odometer is not tracking at all. All the lights are working, but 0 speed shows at all times. Seems that it is more likely to be a mechanical issue but I thought I should reach out here first to try to get some direction on my root cause investigation. I have checked all the fuses and that's good to go. Any hints on where I should look would be appreciated. D.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.