Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

714dre

Contributing Members
  • Content Count

    63
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About 714dre

  • Rank
    Contributing Member

Contact Methods

  • Website URL
    http://
  • ICQ
    0

Profile Information

  • Gender
    Male

Profile Fields

  • From
    SoCal
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    99 carrera
    55 tbird
  1. I've got a 2001 C4 and noticed the same thing... It is less pronounced compared to my 99 C2, but still very noticeable. Since then I put on the factory GT3 style front bumper, and the floating feeling is completely gone. It is amazing how a seemingly subtle change to the aerodynamics will have such a great affect on the driving experience. My other option was to listen to my girlfriend... "You should not be driving that fast anyway"
  2. Sorry, Wow, I can't find that receipt in my records... but am 95% sure I got it through Sunset Porsche Phone: 1-800-346-0182 If I had to guess I'd say 1300, but it was a few years ago and really not sure.
  3. You may want to talk with the shop who will be doing the work (if not doing yourself)... When I had my bumpers updated, they said they would do one of the off brands, but very much recommended factory parts. They were concerned fitment would not be perfect, and would only guarantee absolute satisfaction if factory parts were used He showed me some pics they had done of a couple other cars with non-Porsche parts, and though looked ok, it was enough to convince me to get the real stuff. The line where bumper met the hood were not perfect.. Just tiny variations of that curve where the gap was smaller in the center than on the sides. Slight, but enough for me. I did the factory GT3 front bumper on my 2001, and it came out perfect... I did leave the basic sides, and it looks fine to me. I can't help you on the spoilers.
  4. Another tip for cleaning your windshield is #0000 Steel Wool... (make sure it is #0000) Only thing to keep in mind is obviously dont get it wet or the steel wool will rust. I've also been told it works great on chrome, but that I have not yet been brave enough to try.
  5. Any chance you could provide X74 kit part # for 2001 Carrera 4 6Speed?
  6. I did not attempt to replace just the voltage regulator... My vehicle has just over 115k miles, so I figured it made sense to swap out the entire alternator.
  7. For anyone who found this post via searching: Replacing my alternator did fix the problem... and if you have to change the alternator, you might as well do the belt at the same time.
  8. Guys, Am having some strange issues with my 2001 Carrera4. The car has sat for several weeks, with me starting it for a few minutes every week or two. Now that I finally am able to drive it, I took her for a mellow ride (as opposed to driving like i stole it) Everything seemed fine until after a few miles of driving at operating temp, several of the dash warning lights came on. So, I drove it the few blocks back to my house... the whole time everything felt fine. Turned the car off, checked fluids, hooked up a meter to battery. Everything looks good. Minutes later I decided to turn her back on, and I get what is in the video linked below... RPM is constantly surging, the voltmeter in the dash is going from about 11-11.75, several of the warning lights are on, and the instrument lights that are on will dim with the RPM surges. After that I have noticed that with the key in the ignition, but with the car off, voltmeter shows about 11/11.5. Check with my handheld meter on the battery it shows just above 12 volts... Battery is about 3-4 months old. Any pointers? I am really jonesin to drive her. Also I should mention, I am suspicious of the accuracy of my handheld meter... it is a cheap one, and several years old.. though seems correct on my other cars. Thanks
  9. Thanks guys. I did get the washer on the cap and I'm confident that connection is good. I'm thinking its leaking at the other end since thankfully it sounds like my system doesn't have a leak. so with the bleeder leaking slowly, would it even matter if I did the fluid by only filling the reservoir, not the motive? I think I've read about that method on here, and at least I could do the flush this weekend.
  10. I think I may have a leak in my fuel system. I just purchased a Motive bleeder, and did the initial 'pump it to about 10PSI' to ensure no leaks before doing the full flush. Well, it does not hold the pressure... within a few minutes it will drop a few pounds. It is slow, but is definitely leaking. I disconnected everything, reconnected and tightened as hard as I dare tighten it, but get the same result. My question for the group is what is my best bet on diagnosing this? I don't see any leaks on the ground below the car... The brakes feel fine on the car. At first I thought maybe the power bleeder connection to the reservoir was it, but I tightened it so much I am pretty sure I can rule that out. So guys, any tricks to tracking this down? Thanks
  11. My Cargraphic mufflers are amazing. No drone, German made, and orgasmic sound.
  12. I have heard it can be made to work... but the wiring has been changed, and though you can move the mirrors with the little directional pad in the cockpit, it moves in different positions than expected. hope that helps.
  13. though i haven't heard of a faulty ignition lock assembly causing this specifcally... I know it can cause all sorts of wierd eletrical gremlins... when mine was going bad, my a/c would only blow hot air from time to time. have you had any issues with the key sticking or difficulty turning the key in the ignition?
  14. Even if the frame is not bent, and you are able to repair the exterior, the interior, front suspension etc etc... Then you get to think "Is the engine ok?" If it has just been sitting there a few years, well, good luck running that motor for any amount.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.