Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Chucksta

Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Chucksta

  • Rank
    Member

Profile Fields

  • From
    Australia
  • Porsche Club
    No
  • Present cars
    MY 2003 996 Carrera Cabriolet
  1. Forgot to say that the car has only done 17,000km You didn't say if the wheels were17, 18 or 19 inch, and the size of the tires, and or if the car was lowered. 18" carrera rims, car is not lowered, and stock tyes since new. Could it be that the tyres are just too old? 6 years?? They still have plenty of thread
  2. I have a MY03 996 cabriolet. When I travel above 50km/h and back off the accelerator, I can hear a rubbing noise. It sounds like it is from the front wheels. What can I do? thanks Chucksta
  3. I put the CTEK XS 3600 into stand by and back onto charge (car mode 3.6A) The maintenance light came on (green LED) But then after about 5 mins, it went back to charge (orange LED). I'm now charging my wife's mini cooper (12 V 55Ah) battery. Will see how long it takes to get to maintenance mode (green LED). Also after i disconnected the charger from the 996, I started the car and voltmeter read just over 14V. First time I have seen this on my car. Is this good or bad? Chuck, this is contra to all the reports re the Ctek/Porsche unit. I'll try mine when I get it and let you know
  4. I just bought a CTEK XS3600 for my MY2003 996 Cab I have connected the aligator clips directly to the battery. I left the front trunk lid open and manually disconnected the light infront of the spare tyre. The battery is still connected to the car. I have also left the car unlocked. The charger has been running 20 hours and it has not switched over to maintenance (trickle charge). Still shows the orange LED (charging) How long has everyone else experienced to get from charging to maintenence mode? Also, I could never get the porsche ctek charger to work when plugged into the cigaratt
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.