Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

eason

Members
  • Content Count

    36
  • Joined

  • Last visited

Everything posted by eason

  1. thx for the quick reply. After reading around the forum, a lot of ppl are suggesting it might be a coolant leak or aos. It seems that the classic signs of are that i would see some sort of leakage. but it seems not to be present in my case. also, the coolant and oil seems to be in the right level... i beginning to fear it's a greater issue..btw, my car seems to start fine again now...im so confusedddddddd please help a confused old man out. lol
  2. hi, i recently got my 2004 boxster s (used) about 2 months ago. Today all of a sudden my car won't start. My brother pretty much forced it to start by pressing on the gas pedal at the same time. After that, the car seemed to start fine. Also, before this incident happened, i noticed some white smoke coming of the the exhaust. not only on start up, but as he's pressing gas as well (don't know if this is normal) can anybody help me pleaseeeeeeee. thank you so much p.s the white smoke doesn't really smell like burning oil.
  3. Main issue is that the LCD display in the cluster does not seem to light up unless i turn the light manually. i was under the impression that the light sensor was suppose to light up when it senses that it's getting dark. The actual headlights themselves doesn't bother that much cause they seem to be on all the time regardless of whether or not i turn them on. thx
  4. hi, i have a 2004 boxster s. When i was reading the manual, it said theres a light sensor which led me to think my car has automatic headlights. When I the person i bought the car from brought it back to the dealership to ask, the person said it's not automatic unless it says the word "automatic" on the light switch. (btw, i have litronic). is this true or is the person I bought the car from just trying to cover up something? (also, i live in canada if that makes a difference at all)
  5. eason, I was in your position a bit ago, and I put in the Pioneer Avic-z3 as a new head unit. I ran into a bit of a snag when I tried to connect to the Bose amp. Bose has a proprietary fiber line(MOST bus) running to the Porsche head unit, that will not work with any other system. I reiterate that installing a new radio head unit will make the speakers in the car useless without modification. I had an inverter hooked up to a set of computer speakers for a while in order to have sound in the car. As of this weekend I just installed new MB quart speakers and amp, and it sounds so much bett
  6. hi, im looking into installing an aftermarket deck (with navigation) to my 2004 boxster s with bose. I was wondering if anyone was successful in installing the deck without having to switch out the amp. (im looking to keep the speakers and amp if possible) thanks :D
  7. i seem to have the same problem, mother, did you find the solution to your problem yet?
  8. i've tried but nothing happens. it seems that it only works if i manually turn the lights on. ~_~ with the lights switch in the original position, it doesn't work
  9. hi, i have a 2004 boxster s with litronics. I noticed that the dash doesn't light up at night. is this normal? or is something wrong with the sensor on the dash? thx
  10. hello, i have a 2004 boxster s with bose. I've been reading around and found couple of diy on how to upgrade the sound system. Most of them included changing out the amp. Im still short on cash (going into university next year) and am wondering if the fiber optic out that is listed on their product description page is the same as the one on the MOST system. thx in advance :lol:
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.