Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

lotusrock

Members
  • Content Count

    10
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About lotusrock

  • Rank
    Member

Profile Fields

  • Porsche Club
    No
  • Present cars
    Porsche 996 C2 1998
  1. hi got a 1998 996 C2 and recently changing rears tires from contis to Good Year F1s and handling all of a sudden terrible and dangerous! tried adjusting pressures but appears leat bad at recommended 36 psi. the car steers round bends and corners better than it ever has but in a straight line at 30mph towards just wanders all over the road just as if it's getting blown across the road, i can be holding the wheel dead straight and i'll just move across the road! **** scary! can't think what is wrong so any help would be great..... as i said i've lower pressures to 32 up to 36 but no change. COuld it just be the change of tires? i would have thought alignment but it was perfect before the new tires, thanks
  2. 1998 c2 996. had small coolant leak for a while and eventually got around to sorting over last few days with help from the site. Bumper removal instructions were excellent. Got a shock when removed as i found the air condensors totally shot in the bottom outside of each, think radiators never been cleaned out and leaves and rubbish had been rotting the rads away. Anyway decided to replace these aswell as the rads that were both leaking. Not too difficult to remove and fit new rads with help of 3rd radiator instructions. The fan assembly that came off as one was easier to fit back by seperating from it's bracket first. Anyway, now my problem, i followed the instructions of bleeding the system when changing the fluid but am unsure how much was left in the system when i changed the radiators (think about 2 gallon came out and a further 2 gallon when empty the system using the rear plug) flushed the system of the old fluid as descrided and managed to get 2 - 2 1/2 gallon into the car but thats all ! the first time a flushed the system and had the heater on full but it blew out cold air and i noticed that the temperature warming light was flashed from switched the engine on even though it was cold! HOWEVER, THE next 3 times the heater was fine and hot, however, even though i've started the car and ran it on the drive to about 90 a few times with the bleed nipple open and filler cap on there is no room in the reservoir for extra fliud and the front radiators are not heating up at all even though the fans are kicking in! so not too sure on the following 1) is the system full of coolant? if not how do i get more into the system 2) is there coolant in the radiators and if not why? if there is why no heat? 3) am i running it for long enough someone suggested i take it out for 30-40 minute drive with the bleed nipple open? 4) should you bleed the system with the coolant cap on or off? (i did rise the rear end as suggested) 5) will the thermostat be ok if the fans are working and would the water pump have anything to do with this problem? 6) also, the site mentions that if you replace the air condensors you need to replace something else if the system has been open for a while, what is this and where is it? your help is appreciated lotusrock
  3. Hi, drive 1998 996 C2 3.4 had some xams money burnig a hole my pocket and on a whim purchased a K&N filter and a Cold Air Induction Kit ! arrived last week and surprised to find the induction kit consisted of a bit of plastic tube and a cap to block off the return back into the filter box... can't help feeling ripped off at this stage! Fitted both last week and take the motor out for a spin, sounds a little better, but there appears to be a much smoother power delivery (not sure if power increase but feels like it). Before i fitted it there was also like others have expereinced a power drop or hesitation at 4-5000 rpm which seems to have disappeared, £200 appeared to be well spent! However, one small afterthought was the impact on insurance if any! didn't call the insurance company about the filter but called up to enquire about the induction kit.. the lady i spoke to couldn't find the mod of her computer and in anycase my policy didn't allow mods and the next one that did was £800 more!!!!!! Did a few searches on Confused and Moneysupermarket but neither had the mod option of the induction kit! Can anyone suggest if this mod requires insurance approval and suggest the best insurance company in the Uk? Also, before i decide to take the induction kit off do you think the differences i'ved experienced may be dwon purely to the K&N filter? Cheers Lotusrock
  4. HI, drive a 1998 996 C2 with 66K on the clock and just started to notice a knocking type noise and vibration coming somewhere from the front end. It only starts after about 30 -40 miles and stops after the car has cooled down for an hour or more. someone suggested a wheel bearing may be the cause but can anyone help? cheers
  5. hi, thanks for that. you're quite right it was the siren and it had to be replaced at £190 so fixed but wallet lighter again! cheers
  6. hi, i've got a alarm problem on 1998 uk 996 C2 started a few weeks ago and i've tried but can't fix it. The alarm siren seems to go off for no apparent reason for a minute a a time then off but then straight off again. It's only the siren and not the flashers and the car can be started so the immobiliser is not getting activated. The only way to stop the alarm because the fob desn't turn the siren off is to take the negative battery lead off, however, normally you need the ignition on else the siren would go off but in this case without the key in the battery disconnection kills the siren. It's fine to drive and the siren doesn't go off when it's driven, and ocassionly i can set the alarm and it wouldn't go off for an hour or so. i've checked the normal doors, bonnet etc contacts and all seem ok and no obvious bleep as if something has been left open (have checked it open door and bleep does indicate open door). Checked radio on someone advice and seems ok, tried unplugging siren next to battery but backup siren which i think is the high tone horn still sounds. Someone also suggested locking and unlocking the car a few times then starting it up but seems to have no effect and not sure if there's a certain way of doing the locking and unlocking in a certain time frame. Tried looking through the workshop CD a have but 90 pages of alarm info and all dutch to me! can anyone help? mike
  7. HI, i've a problem with my alarm and have been advised to get a pst2 test done to locate the problem, however, i want to drive the car to the garage without the siren going off! i've tried unplugging the siren to the left of the battery however there appears to be another internal siren somewhere can anyone help me locate it and is so how can i disable it? thanks
  8. Hi,just noticed that when sitting in my C2 996 1998 a noise coming from the ventilation unit in the centre consol, sounds like a hum or a whine/ fan and is on even when the ac and ventilation is off but the ignition on, it's still there when the enginee is turned on but obviously less noticable due to the engine noise, anyone any ideas how to get rid of it? thanks
  9. Hi, help please, my alarm on 1998 C2 has just starting going on for no reason that a can find at all, it started last night and went off for about a minute then would turn off, it appears to be just the alarm and the indicators don't flash and you can start the car so the immobilsier isnt being activated. In the end had the discount the battery as the neighbours didn't look happy. someone mentionned that due to lack of use ie about 2 weeks and the cold weather that the battery backup on the alarm siren had flattened, i took the car on a drive and that alarm didn't go off for 12 hours but at 2am so again neighbours not happy! do you think this is the problem or something else and if so would a trickle charger help? :(
  10. HI, new here and not that techy so help please, 996 c2 1998 reversing lights not working, have checked bulbs and fuse B5 all ok, any thing else i can check? thanks
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.