Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Jerry996

Contributing Members
  • Content Count

    20
  • Joined

  • Last visited

Everything posted by Jerry996

  1. I am in the process of replacing the struts on my 99 C4 and saw that you also had issues removing the front axles. I have sprayed it with PB Blaster for about three days and even used a press tool with no success. How did you finally get yours removed? Thanks in advance, Jerry

  2. I decided to order all the coolant hoses for my 99 C4 (got them from Pelican) as they are now getting pretty old. I stopped in at my independent shop yesterday and was told that they have done this once for another client and the labor (inclusive of a water pump R&R) was 22 hours. Anyone out there know if this is reasonable? There are a lot of hoses (and coolant vent tubes) but I'm thinking of breaking this up into smaller jobs over time if its going to cost $2K in labor to replace the coolant hoses. Any info is much appreciated, Jerry
  3. I have a 1999 Carrera 4 and need to replace my rear tires. I'm currently running Continental Contisport Contact 2's, 225-40-18 in front and 285-30-18 in the rear. Since my front tires are at about 50% and the Contisport Contact 2's are discontinued the Tire Rack recommended the Extreme Contact DW tire. The 285-30-18 tire has been on back order for several months now but the 285-35-18 is available. Is this a good choice for me or should I wait longer? I am at the wear bars on the insides of my rear tires and fear that I'm going to get into trouble on a wet day. Thanks for your time, Jerry
  4. I have the same exterior/interior codes on my 99 C4 and initially thought BB was graphite grey but it is space grey.
  5. I thought that I'd end this thread with the answer to what finally solved my problems. Perhaps this will help people with similar issues. The electronics in the Throttle Body turned out to be the culprit. I had changed out the MAF with no change and the dealer remapped the ECU with no change. The throttle body was cleaned thoroughly and that also rendered no change. I took it in to my independent who drove it from cold one morning and he noticed a lot of noise (loud clicking sounds) coming from the throttle body. The codes retrieved at that time were P0102, P1503 and P1506. P1503 and P1506 wer
  6. According to Sunset Porsche the throttle jacking unit is part of the throttle body electronics. According to them it is only available with the throttle body, not on its own. A fairly reasonable price was quoted for the throttle body, around $220.
  7. Yes, it is a Carrera 4, so Motronic 7.2, I'm sorry if I wasn't clear enough. I swapped out the throttle body this afternoon, it took about 15 minutes and is a very straight forward swap. The gasket is also very simple to swap out. I drove the car this afternoon, it had been parked for four days and no surging or hesitation at all (first time in ages without cold start issues.) I will drive it in the AM when it will be around 45 degrees and see how it behaves but I believe the electronics (throttle jacking unit) incorporated in the throttle body was the culprit. The throttle body was actually r
  8. I'm changing out the throttle body on my 1999 C-4 with e-gas next week and was wondering what to expect. I looked in the DIY forum and here but did not see a posting that describes it. Can I re-use the bolts? Does the ECU (DME) need to re-learn the new throttle body? Any special tools needed? I'm changing it out because its making lots of funny noises and does not behave well when cold (surging hesitating) codes are P0102, P1503 and P1506, once it warms up all is fine. Already replaced MAF with no change. Any information is much appreciated. Thanks, Jerry
  9. I need to order this part and neither Sunset nor Pelican knows what it is. I have a 1999 Carrera 4 with E-gas, part number or any information would be much appreciated. Thanks for helping a newbie, Jerry.
  10. When you say "throttle jacking unit" does that mean throttle position switch (996-606-116-00-M14) or something else? I can't seem to find a part named throttle jacking unit.
  11. Well I didn't know that the "throttle jacking unit" attached to the unit. thought maybe it came with the throttle body if replaced as a whole. Which is why I posted the question. All the mechanic told me was that the throttle body was extremely noisy and possibly needed to be replaced. Could the noise be from the jacking unit? Could both need replacing? Is the jacking unit serviceable? If you can send me a part number then I'll order the jacking unit and see if that does it? Thanks, Jerry
  12. Update: need opinions. The symptoms are getting more pronounced now. The surging is becoming more frequent (probably the cooler weather). Took the car to my independent to have the air bag harnesses replaced under the seats and had them diagnose my cold start/surging issues. I have new codes now, P1503 and P1506 as well as P0102. The mechanic stated that the throttle body was very noisy and most likely causing the surging and hesitating problems. He recommended the throttle body be replaced. Is that my best course of action? If I order a throttle body does that include the electronics that m
  13. Ok, thanks for the reply. Suppose its time to invest in some durametric software, first I have to figure out how to get this Mac to run windows.
  14. No, the MAF is a new unit from Pelican. I don't believe the dealer tested it in some way. That's what I'm after, how do I test the MAF and wiring? I do not have Durametric or anything else. Jerry
  15. Hi, I have a 1999 C4 (E-gas) that is still exhibiting the following problems. When first started (from cold) it idles fine, after taking off it tends to bog between 2-3000 rpm's and then the ABS/PSM warning lights come on. It then tends to surge slightly, giving and releasing throttle without moving the gas pedal. Once warm (5-10 minutes, when it reaches 180) it drives perfect. Does it no longer need the MAF after its warmed up? The code it is throwing is P0102 and 5525 according to the dealer, they remapped the DME with no change. The MAF has been replaced (no change) and I believe this me
  16. Well I started the car this morning and the idle seemed to be better but still hunting a bit after the air pump turned off and the idle dropped. I would say the hunting is minimal, less than before. The bad news is that it was 70 degrees here this morning and perhaps that's why it ran pretty good. It was only slightly sluggish taking off and the ABS/PSM lights did not come on. Perhaps the throttle body cleaning did the trick, will have to wait for a cooler morning to be sure. Perhaps the ECU still has some learning to do with the new MAF? I will have the dealer check codes and tell them about
  17. So if I understand correctly....you replaced the MAF, but did not clear the codes. You should clear the codes...if you do this via a battery reset, you will have to let the ECU re-learn. I would clear them, run the car and then read the codes again. I don't have any way of reading codes yet, need to invest in an OBDII reader. Are the relatively cheap ones worth buying? Amazon sent me an offer for an Equus 3030 Innova for $59.99 today. I did have the codes cleared by a shop before installing the new MAF and I did not drive it again until the MAF was installed. First time I drove it (eng
  18. I have not had codes read since replacing the MAF. I simply replaced it after my tech said codes P0102 and 5525. I was hoping that the surge and hesitation would go away when the engine was cold (after replacing MAF), it did not. I just cleaned the throttle plate area and will now have to see how it behaves this evening or tomorrow morning. I thought that maybe I'd need to remove the battery power after replacing MAF (to clear ECU), I thought that I'd read that here somewhere but wasn't sure. If the surging when cold only is not the MAF then it must be something else, we'll see if the throttle
  19. Ok, since I've already replaced the MAF, I'll clean the throttle body and see what that does. The brake lights work fine and from what I've read the ABS/PSM warning lights are somehow connected to the MAF issue. I had also read here that the MAF had little to do with idle/low rpm issues as it only came into play at higher rpm's. Thanks, Jerry
  20. I have a 1999, C4, manual trans. Lately the car has been surging when cold. You can hear the engine surge (minor hunting) when its idling (maybe 50-100 rpm's.) The car tends to bog after taking off and then the surging (increase and decrease in engine speed without moving the accelerator) becomes more noticeable at speed. The ABS and PSM warning lights usually come on after that, usually within 3 minutes. My independent pulled codes P0102 and 5525. I replaced the MAF (plus air filter and cleaned the airbox) with a new unit a few days ago with no change. After the car warms up 5-10 minutes, the
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.