Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

bdodd444

Members
  • Content Count

    2
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bdodd444

  • Rank
    Member

Profile Fields

  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    1987 Porsche 944
  1. I posted a while back about my 87 944 not starting. I finally towed it in, and after about $800 in tune up, draining old fuel and both Crank Position Reference Sensors. The mechanic says the car will turn over but once the key is released it loses fuel pressure and won't continue running. He says he is stumped and it will be 6 hours of labor at least to figure out what is going on. He says the fuel pressure is fine for starting but there is none for running. He says there are two different signals sent to the fuel pump. I believe I have all of this right. If anyone has any ideas, I would appreciate it. I'm pretty close to donating the car, but would be willing to try one more thing.
  2. I have a 1987 944. It sat for 6 months in my garage, while I replaced the headlight after an encounter with a deer. Ran great before, now it won't start. Checked DME, spark at the plug, put a 1/2 tank fresh gas with an additive. I'm thinking fuel filter may be next on the list. Any suggestions would be greatly appreciated. Thanks. Brian
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.