Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

jimmyw71

Members
  • Content Count

    2
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jimmyw71

  • Rank
    Member

Profile Information

  • Gender
    Male

Profile Fields

  • From
    Phoenix, AZ
  • Porsche Club
    No
  • Present cars
    2004 911 C4S Cab
    2007 BMW X5 4.8
  • Future cars
    2014 BMW X5 4.8 Dinan tune to 496hp
  • Former cars
    2007 Honda S2000
    2003 BMW X5
  1. I'm dealing with the same issue on my 04 C4S. I checked the spring and all looks good, but it just can't overcome the weight of the hood (trunk) itself. I have to pry it open with my fingers to get to the release latch. Can you remember how you bent the spring back so that it was stronger? I don't see much room to work around it, but am eager to try anything. Funny, a '77 Toyota never had this problem. hmmf! BTW, I did try moving the mechanism to different locations in case it was an alignment issue, but it's exactly the same, if not worse, in different locations.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.