Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

gbennett

Members
  • Content Count

    2
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About gbennett

  • Rank
    Member

Profile Fields

  • From
    Alexandria, VA
  • Porsche Club
    No
  • Present cars
    2000 Intrepid
  1. Thanks for the quick replies gents! I just sources some Pentosin, so I'll try to top off the power steering fluid and see if that helps. I'll report back!
  2. The car is a 2003 C4S manual transmission. It just turned 70k miles this week. I was (still am) trying to diagnose an ever-increasing squeaking coming from the engine bay. My first effort was to remove the poly belt to check the pulleys for excessive play. When I got to the alternator pulley, I noticed that I could freely turn the pulley counterclockwise while holding the alternator still by holding on to one of the fins, If I tried to turn the pulley clockwise while holding the alternator from turning, it would not slip. I see that the engine turns this pulley clockwise naturally, but is there still a way this could be causing the noise? As for the squeaking, it comes on as soon as I start driving (it does't squeak at idle) and comes on intermittently. It initially was more closely tied to turning, but now squeaks regardless of turning, accelerating, etc. That is, I can be cruising with minimal load on the engine and it still squeaks on and off. Also, the squeak does not change get higher or lower with engine rpm. I noticed it this morning for the first time, and after driving maybe 20 miles, it has gotten increasingly more frequent. Any ideas? I appreciate your help. This board has come to my rescue numerous times! Greg
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.