Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

billyqureshi

Members
  • Content Count

    2
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About billyqureshi

  • Rank
    Member

Profile Fields

  • From
    england
  • Porsche Club
    No
  • Present cars
    986 (2004 boxster s)
  1. hi, apologies if been covered elsewhere but i have done searches and cant find answer... i have 986 boxster s 2004 the windscreen washer jets arent working - local garage says the washer motor isnt being activated when the stalk is pulled (no feed to washer jet). they say its the stalk that is faulty and that i need a new one. ive looked on the parts catalogue and i think i need part 996.613.215.10 EWC as my car has onboard computer but no cruise control. the question i have is whether or not i need to get this part, or whether its possible to just buy the basic switch that doesnt have computer or cruise control stalks (which is much cheaper) and take off the wiper stalk and fit it to my vehicle. also, is if believable that a faulty stalk can be responsible for failure of wash jets when it still activates the wipers when pulled? its only the water that doesnt come out! all other wiper functions work ie intermittent, continuous etc etc. thanks in advance for your help
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.