Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

theswishh

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About theswishh

  • Rank
    Member

Profile Fields

  • From
    San Diego, CA
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    99 968
  1. Hi All, I was hoping to get some feedback from any of you that can help. I have a 99 986 with 110k miles. The brakes began to stick a little when I would take my foot off the brake pedal. After a week of driving it like this the brake became even worse and would not disengage after I would apply braking pressure to slow down or stop. I would have to slide my foot under the brake pedal to lift it up and disengage the brakes! My pads were very low so I decided to replace the pads to see if this would help and it didnt. I then replaced the master cylinder today hoping this would be the cause and once again it wasnt. I took extra care in bleeding the system too but the brakes still wouldn't fully let go. I did notice a large amount of rusty water that had accumulated in the brake booster when I separated the master cylinder and brake booster and have read that this is most likely the culprit. I just wanted to see if anyone had other ideas as to what the problem could be before I shell out more money on a new booster? Could it be a stuck caliper or something even simpler? Thank you very much in advance!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.