Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

1braincell

Contributing Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About 1braincell

  • Rank
    Contributing Member

Profile Information

  • Gender
    Male

Profile Fields

  • From
    san diego, ca, usa
  • Porsche Club
    POC (Porsche Owners Club)
  • Present cars
    2003 996 TT
  1. Thanks for the update. I replaced the oil about 1,000 miles ago and there is no change in the level according to the computer gauge so I don't believe that there is any significant loss occurring. However, I do notice a drop or two on the garage floor every few days. Will probably ask the dealership mechanic to give an opinion the next time I'm there.
  2. Hi, I'm having a similar leak on the right side of the crankcase of my '03 TT. Just wondering if you've had any further issues with this? Thanks
  3. An update ... I cleaned the area where the oil was evident and left the car overnight. The next day I could see a small trail of new oil but not enough to drip onto the cardboard placed under the engine. I dabbed the wet area with a clean tissue and noticed that the color of the fluid was clear yellow. Since the last motor oil change was performed about 7 months ago I would have expected any oil leak to be a fair bit darker in color. The leaked fluid is also a bit thinner that 0w40 weight oil as well. Following the instructions in the handbook I checked the power steering level and foun
  4. Hi, I noticed today that there was a small puddle of oil under under my '03 996TT, 42K miles (which I've had for one month now) near the back center of the engine. The car hasn't been used for the last 9 days while I was away and prior to this didn't see anything unusual. Based on the location and the pictures could anyone suggest any places I should look at in particular. From my reading RMS leaks for the 996TT are quite rare. In addition, the oil pressure gauge has been acting up over the past month and I'm not sure if the two may be related. At first the oil pressure gauge was jum
  5. Hi, I'm having a strange brake problem and was wondering if anyone could shed some light. When I first start the car in the morning and reverse out of the garage the brakes are almost nonexistent and I have to push down quite forcefully to keep from moving. After I get going though, the brakes seem to get better and the force required to stop the car becomes less. I have bled the system and checked the vacuum hoses for and leaks. I'm thinking that maybe the brake booster may be the culprit. Has anyone had any similar issues? Thanks, Jay
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.