Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

GeraldC48

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About GeraldC48

  • Rank
    Member

Profile Fields

  • From
    Aurora, IN
  • Porsche Club
    No
  • Present cars
    2008 Carrera S
  1. I just had my oil changed on my 2008 Carrera 2S and I've noticed that the oil pressure is almost buried at 5 bars constantly on the guage whether the car is cold or when it is running with 200+ deg. of oil temp. I've checked the oil level and it seems to be at the full mark however a couple of times it was over the full mark. Is this normal or should I have Porsche drain off a 1/4 qt.
  2. I have a 2008 Carrera S and the auxilliary fand doesn't run after I turn off the ignition however it runs for 4-5 minute when I turn the key to the on position. Is there a faulty sending unit or themostat?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.