Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Toothzilla

Members
  • Content Count

    7
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Toothzilla

  • Rank
    Member

Profile Fields

  • Porsche Club
    No
  1. I just put some pieces of felt under my aluminum ring, and the buzz went away.
  2. With Spider's help, and the manual, I realized that everything is A-OK. thanks anyway, Chris
  3. Niello replaced my gauge cluster due the oil level not turning off after starting, and tonight, I noticed the three low level lights in the interior won't turn off. I don't remember them staying lit before. The lights are the two small ones near the door handles and the one up above by the rear view mirror. Also, the indicator lights for the trunk and engine lid are still lit up. Did they mess something up and is the fix easy because I don't feel like driving 4 hours round trip to have the lights reset. thanks for your help, chris
  4. Just found out it's backordered. Won't be here for a month or so. Did you get Michelle's email? She was wondering if she could have Tori's address. Chris
  5. I'll give him 5 minutes. It'll probably take me 65 to do mine!! A new 930 wheel is on the way for my red one. Chris
  6. I bought mine from performance products at the beginning of June, and they won't arrive until the middle of august, due to being on back order. Glad I finally found this board! Chris
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.