Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Dave1971

Members
  • Content Count

    3
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Dave1971

  • Rank
    Member

Profile Fields

  • From
    Reno
  • Porsche Club
    No
  • Present cars
    2002 Porsche boxster S
  1. The sensor is connected, when I unplug it the light stops flashing
  2. Yesterday I had my coolant expansion tank replace, after driving it away from the shop the temp light began blinking slowly (which usually indicates low coolant or engine compartment fan faulty) I checked the coolant level and it was fine, today I ran the car and let it sit running for a while and never heard the familiar noise of the engine fan coming on, what could have happend to the car during the installation to have this problem? I would like to have something to say to the mechanic when I bring the car back. Thank you for any insight on this problem. 2002 Boxster S Manual Tranny
  3. My 2002 Boxster S keeps blowing the fuse in the rear of the radio. When I replace it the radio works. After turning the radio back on it blows the fuse. I want to replace the radio with a newer model of radio but those also have fuses in the back of them. My car has the Bose system with door speakers. I don't want to replace the radio if the problem with just blow fuses on the new unit. I have searched many threads but not have come across this problem (Fuse on back of radio repeatedly blowing. Any insight to this problem would be greatly appreciated. Thank you!!!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.