Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
tonicinwhite

944 Turbo with Boost enhancer and stage2 chips

Recommended Posts

ok im new to this one and i have a question that i hope someone can help me with. i have an 88 944 turbo with 92,000 miles. the car came with autothority stage 2 chips and the small oriface that went in the banjo bolt... very quick, but decided to install a lindsey racing boost enhancer in which i was told to remove the oriface in the banjo bolt so i didnt have to worry about over boosting. so i left the chips in the car and installed the boost enhancer on stock settings. ALOT faster, but i notice that when i jump on it hard through a few gears for the first few seconds there is smoke coming out the exhaust...

is this due to the fact the power curve has been changed?

any ideas and is this possibly normal when these cars take off like a scalded dog

Thank you very much

Jeff

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Could be related to that O2 sensor :)

ok im new to this one and i have a question that i hope someone can help me with. i have an 88 944 turbo with 92,000 miles. the car came with autothority stage 2 chips and the small oriface that went in the banjo bolt... very quick, but decided to install a lindsey racing boost enhancer in which i was told to remove the oriface in the banjo bolt so i didnt have to worry about over boosting. so i left the chips in the car and installed the boost enhancer on stock settings. ALOT faster, but i notice that when i jump on it hard through a few gears for the first few seconds there is smoke coming out the exhaust...

is this due to the fact the power curve has been changed?

any ideas and is this possibly normal when these cars take off like a scalded dog

Thank you very much

Jeff

Share this post


Link to post
Share on other sites
ok im new to this one and i have a question that i hope someone can help me with. i have an 88 944 turbo with 92,000 miles. the car came with autothority stage 2 chips and the small oriface that went in the banjo bolt... very quick, but decided to install a lindsey racing boost enhancer in which i was told to remove the oriface in the banjo bolt so i didnt have to worry about over boosting. so i left the chips in the car and installed the boost enhancer on stock settings. ALOT faster, but i notice that when i jump on it hard through a few gears for the first few seconds there is smoke coming out the exhaust...

is this due to the fact the power curve has been changed?

any ideas and is this possibly normal when these cars take off like a scalded dog

Thank you very much

Jeff

Sorry man, I really don't know the answer to your question. But are you in the Alexandria area a lot? I have taken my car to Minh once: Pitstop in Alexandria, (they bought out Autothority)

I have been using this one mechanic in Fairfax, VA for just major jobs (timing belt, rollers, etc) Autobahn Services: Jose, real honest guy.

I am going to be working on my 87 944 turbo soon, im getting my license back.

I work out in Sterling and stay in fairfax. Do you do a lot of DIY with ur ride?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.