Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

    You can remove these ads by becoming a Contributing Member.

  • Replies 131
  • Created
  • Last Reply

Top Posters In This Topic

2002 c4s.

second owner. I have had the car 2 months. from 64000. now has 68000 (including 550 mi at Watkins Glen).

RMS repaired 2007 (appears to have be repaired by engine replacement - not confirmed)

at purchase - replaced water tank (leaking), all fluids.

need rear brake pads in next month

daily driver. great car.

Link to post
Share on other sites
  • 7 months later...

I have a 1999 carerra with tiptronic. 140K miles. daily driver. only issue was a broken pulley about 15k miles ago. now have a CEL codes show MAF. cleaned it but light came back on. will clean again. may need replacing. thats it. no garage queen here. drive it and have far less problems. never had a RMS.

Link to post
Share on other sites

2004 Atlas Grey C2 Carrera 43K no problems except previous owner kerbed it and cracked a wheel, also one headlight yellowed, changed out wheel and polished headlamp as per instruction on here with the 3M kit, looks great now, daily driver 15 miles each way to work

Link to post
Share on other sites
  • 2 weeks later...
  • 4 weeks later...
  • 3 weeks later...

2001 C2 77000 Miles no issues. Drive it hard but not reckless. No garage queen but she does not leave when there is snow outside...due to the salt and grit used to melt the snow!

Edited by Loren
Link to post
Share on other sites

2000 C2 Tiptronic 90,500 miles. Only major problem was the power steering cracked out shortly after I replaced the water pump as a precaution at 90k. I believe that might have been mechanic's error. Other than that, I have been following the recommended service schedules for belt, plugs, brake bleeds, filters, and tranny service. I do change my oil every 5,000 miles though. :jump: :D

Link to post
Share on other sites

996 Cs MY99 82500 miles,. No mayor problems. Replaced the starting switch with the new version. Starting problems, replaced battery with an Optima and all OK. Recently bought a Durametric kit and no FAULTS! Awesome car.

Link to post
Share on other sites
  • 7 months later...

I just bought a 2001 c2 Cab with 31,000 miles, two owners, doubt if this car has ever been tracked, Porsche says no apparent problems, car runs like a rocket. I drove it back from Austin Tx to Tampa, absolutely nothing needs doing.

Link to post
Share on other sites

I would like to know what mileage everyone has on the 996. Also, if there has been problems with the car, please list it.

Thanks!

Please check the high mileage roll call at the beginning of this site. Many 996s with more than 100K miles listed. FYI, I am new to this and just purchased (August 2010) a Guards Red 1999 C2 cabriolet that had 27,500 original miles. The original owner must have driven it hard because during replacement of the RMS and IMS beraing with the LN kit, the clutch and flywheel showed a need for replacement. FYI, my IMS bearing appeared to be in excellent shape w/o signs of degradation. The car was in very good condition and it such a blast to drive.

Link to post
Share on other sites

I would like to know what mileage everyone has on the 996. Also, if there has been problems with the car, please list it.

Thanks!

Just picked up an '03 w/27K from my friend who was the original owner. Besides a steal, zero defects so far.

Link to post
Share on other sites
  • 4 months later...
  • 3 weeks later...

2002 C2 coupe.

168,xxx kilometres. It had a new engine at about 50xxx kilometres.

Car runs great, not to be cliche, but it drives like new.

Not a ding on it anywhere, although some rock chips and a scratch or two.

I just cracked my oil pan so replaced it with the X51 part and I just replaced the steering rack. Other than that and a coolant tank, it's only required regular maintenance. Oh yeah...a $15 ignition switch.

Link to post
Share on other sites

99 6sp coupe.

74,000 miles.

1st owner put 50k on car with great service records. Had it approx. 10 yrs.

2nd owner put 20k on car with no records. I got it and did a complete 60k service including new brake pads front and rear.

Looks and runs great.

Link to post
Share on other sites

1999 C2 cab, 6 speed, 61,000 miles. Vacuum switch on air pump failed, spark plug tube O rings leaked, small seperation is occuring between the plastic window and canvas, about 3" long right now. That's about it. Full (large) leather interior looks like new. Zero rust.

Needed a new clutch at 60K miles, while I was in there I replaced the AOS, IMS bearing (LNE ceramic now) and RMS. RMS never leaked. factory IMS bearing was tight and no seal failure. AOS was fine too.

Happy with car, it's a good runner.

Edited by Cefalu
Link to post
Share on other sites
  • 1 month later...
  • 1 year later...

1999 C2 cab, 6 speed, 61,000 miles. Vacuum switch on air pump failed, spark plug tube O rings leaked, small seperation is occuring between the plastic window and canvas, about 3" long right now. That's about it. Full (large) leather interior looks like new. Zero rust.Needed a new clutch at 60K miles, while I was in there I replaced the AOS, IMS bearing (LNE ceramic now) and RMS. RMS never leaked. factory IMS bearing was tight and no seal failure. AOS was fine too.Happy with car, it's a good runner.

I know this is an old post. I was wondering how the LNE bearing has performed over the last couple of years.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • RennTech.org Store at Amazon.com



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.