Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
spankey

996 engine warning light (1999)

Recommended Posts

Just bought a 1999 cab 996 and after driving it home for 270 miles the engine warning light came on. The light stays on and I had the code read as P1125. I just bought the car yesterday and need to know if I should return it or if this code should be just reset? Being new to owning a Porsche any info on this would be appreciated.

Also the car only has 36000 miles.

Edited by spankey

Share this post


Link to post
Share on other sites

P1125 Oxygen Sensing Adaptation Area 1 (Cylinders 4 - 6) - Lean Threshold

This means that mixture on cylinders 3-6 is too rich and the DMEcan not correct for it.

Potential causes are:

- Fuel pressure too high.

- Fuel injector leaking.

- EVAP canister purge valve open.

Since you just bought the car I would go back and make them fix it.

Share this post


Link to post
Share on other sites
P1125 Oxygen Sensing Adaptation Area 1 (Cylinders 4 - 6) - Lean Threshold

This means that mixture on cylinders 3-6 is too rich and the DMEcan not correct for it.

Potential causes are:

- Fuel pressure too high.

- Fuel injector leaking.

- EVAP canister purge valve open.

Since you just bought the car I would go back and make them fix it.

Thanks for the info Loren.

Would it cause any problems to drive the car today?

Is this expensive to repair?

A little background as we live in Florida we were coming back from picking up the car and I pulled into Automax to pick up some wax. The temp. was 93 degrees so my wife stayed in the car and I left it running. When we took off from the parking lot there was some traffic coming and I got on it coming onto the road. I never even hit 6000 RPM's but that is when the light came on.

Thanks again for your help.

Edited by spankey

Share this post


Link to post
Share on other sites

As long as the CEL is not flashing it is okay to drive the car (as long as it runs ok).

They have to find the problem before any parts/labor estimates.

If you had a P1123 (cylinders 1-3) also then I would say a dirty MAF - but since it is only on one side they need to look at the DME readings to tell if the MAF is working right.

Share this post


Link to post
Share on other sites
As long as the CEL is not flashing it is okay to drive the car (as long as it runs ok).

They have to find the problem before any parts/labor estimates.

If you had a P1123 (cylinders 1-3) also then I would say a dirty MAF - but since it is only on one side they need to look at the DME readings to tell if the MAF is working right.

Thanks for the help.

Share this post


Link to post
Share on other sites

My '99 996 threw both right and left side O2 ODBII errors, and it turned out to be a bad MAF. If I remember the various threads I chased when it happened, it can be:

  • The dirty MAF you already know about
  • An after-market air filter
  • This little rubber connector called something like "oil bellows" (but that threw lots of ODBII codes)
  • An outside chance of a vacuum leak

Good luck dealing with the folks you bought from...

Share this post


Link to post
Share on other sites

Everyone thanks for your help.

Took the car to the local Porsche dealer and it was the MAF. $800.00 later and I am on the road. The good news is the guy I bought it from agreed to pay 1/2 the repair bill. I am ok with that as I bought the car as is.

Thanks again for the responses.

Share this post


Link to post
Share on other sites
Everyone thanks for your help.

Took the car to the local Porsche dealer and it was the MAF. $800.00 later and I am on the road. The good news is the guy I bought it from agreed to pay 1/2 the repair bill. I am ok with that as I bought the car as is.

Thanks again for the responses.

$800.00 for a MAF, that's a whole lot of money for a part that only takes 5 minutes to replace.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.