Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

1999 C2 Coupe, 6 speed manual, RHD

When I start the car and do the electronic oil level check I get the usual count down timer and then the gauge just flashes at me with no reading. After consulting the manual it seems this is because the sensor is faulty. I have checked the oil with the dipstick and its fine.

Anyone experienced this before and if it is the sensor is it easy to do a DIY replacement?

Thanks, Al

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • 1 month later...

I finally took my car to an independant Porsche specialist. They found that a mouse had got into the car and completely chewed through the cables that connect to the oil level sender unit! Thankfully they were able to make good the connections and now I am operational again!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.