Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Removed the original radio, amplifier, and 6 CD changer and installed a DUAL HD radio with AUX input and MP3.

The original setup was ok on FM but had alot of static on AM.

At first without power to the antenna amplifier received no AM stations. Next connected the white antenna amplifier wire to the blue DUAL antenna amp wire and got some of the better AM stations but those didnt go to HD until I drove closer to LA. Also the FM HD stations are going in and out of HD as I drive around. The antenna amplifier is helping but I dont know if it is 100%.

Has anyone successfully improved radio reception with the little wire in the windshield? I would like to jump around the antenna amplifier or replace it. Anyone know where the ant amp is or had luck replacing it?

Thanks

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • Moderators

Pull off the cloth hanger and remove the screw, pull off the trim and pull backwards. The amplifier is on the right A pillar.

Link to post
Share on other sites

Removed the amplifier and jumped around it with a wire. Reception seems to be the same or slightly better without it. Has anyone replaced the amplifier and seen improvement?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.