Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Background:

2001 C2 - 78,000 mi, 6 speed, US car

Bought used in Aug and have put on about 1,000 mi since. I am second owner.

Original owner had most work done at dealer (where I bought it)

Issue:

Today while driving to work, stopped for coffee, came out and saw coolant leaking from an overflow hose from the coolant tank. Small amount, but coolant has gone from about 1/2 way between marks on the tank to the low level mark on the tank. Engine did not overheat, and runs normal temp, slightly above the 180 mark. Does not have any leaks of fluids of any kind otherwise. The engine was off when the discharge happened.

Drove car for a while after notcing fluid on ground, discharge has not returned, car ran fine. Checked under the car when I got home and things look fine.

Only other item to point out is that on some occassions with hot engine, I have noticed a slight smell of antifreeze, but no leaks and no loss of fluid in the tank.

I would not think it normal to spit out coolant, especially without an overheat situation. Is there something with this vent or valve in the tank, possibly?

PPI was done by local independant, and everything checked out.

Thanks.

MP

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

I have a '99 C2 and I had a coolant leak crop up this past week. Dealer saw it today and said its a cracked expansion tank. From what I've heard, this is common, and the leak won't manifest itself until the coolant system is pressurized and warm. Like you, I also haven't had any overheating, but until I can get an expansion tank replacement, I drive with a gallon jug of distilled water, just in case. Good luck with yours...

brian

Link to post
Share on other sites
Either a bad cap and/or tank.

If the cap part number ends in 00 then it needs be changed.

If the cap is 01 or later then it is likely ok and the tank is leaking. In a few cases both are leaking.

New cap seems to have done the trick. BTW - Part number stamped on new one ends in -02. Smell is gone as well, plus the engine actually seems to running a few degrees cooler. Love it.

Thanks,

MP

Link to post
Share on other sites
  • 2 weeks later...

was that smell you discovered only when warm or after a cold start?

i have had a smell on cold starts, and there has been alot of residue along the top of the coolant overflow tank (WHITE COLOR)

the coolant level hasnt dropped below minimum but it definately doesnt smell like oil.

thanks

pj

Link to post
Share on other sites

I have a 99 Cab and have been getting the coolant smell for a while. I was getting a slight discharge around the lip on the tank so I replaced the cap. This has cured the discharge but not the smell. The only mystery in my case is that the coolant level doesn't seem to go down. I put a small pencil line on the tank about 3-4 months ago and have checked it regularly when cold and the level never seems to change. The smell is only evident when the car is warm.I guess I need a new tank.

Cheers, SM

Link to post
Share on other sites
  • Admin
I have a 99 Cab and have been getting the coolant smell for a while. I was getting a slight discharge around the lip on the tank so I replaced the cap. This has cured the discharge but not the smell. The only mystery in my case is that the coolant level doesn't seem to go down. I put a small pencil line on the tank about 3-4 months ago and have checked it regularly when cold and the level never seems to change. The smell is only evident when the car is warm.I guess I need a new tank.

Cheers, SM

I guess I believe that if the level is not going down you do not have a leak.

There is a bleeder valve on the top of the tank that opens automatically to let air or other gases out - perhaps that is where you get some of the coolant smell from.

Unless that valve is bad it does not let liquid out - and if it did I think you would see the coolant level go down.

Bottom line... I would not change the tank until you have a proven leak.

Link to post
Share on other sites
  • 2 weeks later...

i have coolant spraying out of my 02 cap on my 99 c2. i have replaced both radiators, added the third, changed the water pump changed the thermostat, changed the oil separator, changed the bottle and cap and i find that it starts to leak when i drive over 3k rpm. but no leaks if i drive under 3k. dealers thinks i need a new motor. but the motor drives well, idles fine, any ideas?

Edited by ERIKAZRA
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.