Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Who has replaced front bushings in their '00S?


Recommended Posts

Hi,

I just registered here at the suggestion of Tom M in Sunol, CA. I am a long time frequenter of the Boxster board. I am glad to have found this site.

I spec'd and ordered a 2000 Boxster S tiptronic in Dec 1999, took delivery in April 2000, and I have been extremely blessed to have had an awesomely fun, trouble free car for 4+ years.

I have been noticing minor "creaking noises" from the front area of the car especially while parking for a while now. Most folks have stated that this is due to the bushings. What I'm not clear on is *which* set of bushings. Is it strut tower mounts or the anti-roll bar bushings, something else, or all of the above?

If you have had this problem on your '00 S (or other years), and had it resolved, please shed some light as to which parts needed replacing.

Many thanks.

rick j.

nashville, tenn.

'00 986 S

'98 993 c2

'93 968

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

I had this on my 2000 S - it was the bearing on the wishbone link that goes to the bottom of the strut, the rear one of the two (should make sense when you see them). I couldn't just buy the bearing though, had to buy the complete link - cost about £150 - about $240.

Mike.

Link to post
Share on other sites
  • 5 months later...

I had this on my 1999 and it turned out to be lower control arm bushings. The dealer said that they had to replace the control arms to fix it. They did and the problem went away. It was a creaking sound when the load changed on the front of the car.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.