Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
rjf123

headlights doing weird stuff

Recommended Posts

My headlights starting acting strange last week, and seem to be getting worse with time.

Initially, the right parking light was out. I tried new known good bulbs to no effect. Then, i noticed that with driving lights on, the right parking light would come on, but only dimmly.

A few days later i noticed that with the driving lights on, the right flasher wouldn't flash. (It would work fine with the driving light off!) Then today, the right high beam stopped working properly: it only comes on dimmly, and when the high beams are on, the driving lights come on dimmly (even when they're turned off) and the right flasher again won't work!

All fuses look fine. The right headlamp cluster plug and socket look ok.

I did a search: am i right to conclude that i need a new headlight switch?

Thanks,

Ross

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

while we're on the topic, my 02 C4S with the xenon headlights seems to not illuminate far enough down the road, but it's plenty bright, it's as if it's angled too far down, is there a way to adjust this? (sorry if i'm jacking this thread)

Share this post


Link to post
Share on other sites
while we're on the topic, my 02 C4S with the xenon headlights seems to not illuminate far enough down the road, but it's plenty bright, it's as if it's angled too far down, is there a way to adjust this? (sorry if i'm jacking this thread)

The headlight adjustment procedure is in your Owners Manual.

Share this post


Link to post
Share on other sites
while we're on the topic, my 02 C4S with the xenon headlights seems to not illuminate far enough down the road, but it's plenty bright, it's as if it's angled too far down, is there a way to adjust this? (sorry if i'm jacking this thread)

The headlight adjustment procedure is in your Owners Manual.

Thanks Loren!

Share this post


Link to post
Share on other sites
while we're on the topic, my 02 C4S with the xenon headlights seems to not illuminate far enough down the road, but it's plenty bright, it's as if it's angled too far down, is there a way to adjust this? (sorry if i'm jacking this thread)

The headlight adjustment procedure is in your Owners Manual.

Thanks Loren!

Well, I replaced the headlight switch today. No problem doing the replacement, but my lighting problem remains exactly the same!! The new switch didn't solve the problem. :(

Where should i look next?

It strikes me as interesting that all the problems are on the right side. Could this be a problem with the turn signal switch cluster?

Thanks again,

Ross

Share this post


Link to post
Share on other sites

Check the head light connectors (both, one on the unit and one on the car) for corrosion/high resistance and proper fitting, check the bulbs for right fitting type, placement and voltage, light switch unit (inclusive L/R flasher) on the steering column, wiring, in this order. A swap with a spare light unit, if possible, should already eleminate a failure in the unit self.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.