Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
expensive_habit

New to site...

Recommended Posts

Hi, about three months ago I bought a '77 924 for $300.00. I'm having a few problems with the electrical system and the engine. First the electrics... After playing with some grounds I finally got the RH lights to work front and back. I tore the headlight motor apart and fixed the "not going down" problem, but I still don't have low beams, (I think it might be a relay). Both the front and rear wipers don't work, the turn signals don't work, nor does the flashers. Any input? As for the engine, I'm having a backfire in the intake (I'm thinking a timing issue). I completely tore apart the fuel distrubtor and got it working but it's leaking. That's all I've found for now. Any input and or sources for parts would be great. This is my first Porsche, and even though it doesn't run, I still sit in it and feel like a Million Bucks!!!! I don't even feel that way in my BMW!

Thanks!!

David

expensive_habit

P.S. The "PORCHE" panel that lights up on the back is a little warped. Anyone have a lead on a new one?

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

you need to find a manual for this, the fuel injection is quirky and the wiring is of poor design

the wiring is similar to a 944 type 1

there are a lot of parts sources, just google it

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.