Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Hi there,

I am having some electrical issues with my car, and I am suspecting the battery that was replaced about 9 months ago. I had a shop replace my starter and they told me that the car had "the wrong battery in it" - and that they replaced it with the correct one. About 4 months later some electrical issues start cropping up. It starts perfectly, but some important functions fail. The battery that they put in is a:

Interstate Mega Tron Plus, MTP-93, 850 CCA 1000 CA

Not the battery recommended for my truck on the Interstate site. Can someone let me know if this is an appropriate battery for my car - an 04 Cayenne Turbo? I do not mind using a non-Porsche battery at all, but just want to make sure it is the proper rating and if it is perhaps the source of my woes.

Thanks,

Mark

Link to post
Share on other sites
  • 7 months later...
    You can remove these ads by becoming a Contributing Member.

Hi Mark ,

i´m not sure about availability of VARTA BAtteries in usa , but i have replaced on my 05CayenneTurbo this type : Varta Silver dynamic 12V 110Ah 920A, size is the same like the original one and price here in europe is around 160USD....working smoothly now.

Link to post
Share on other sites

Thanks for the reply,

Turns out my battery was defective, but upon replacing it I still had electrical problems. After much work, I found that it was due to a short in the harness that runs under the carpet on the drivers side. I replaced it with the same item as listed above, which exceeded the minimums for my car, and is still working fine.

Mark

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.