Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, WERE due Dec 4th, 2022. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

High Pitch Squealing Noise Coming From Engine


Recommended Posts

1997 PORSCHE BOXSTER 2.5 H6 ENGINE 5SPEED

Hello, how is everyone doing I have a 97 porsche boxster, my car makes a high pitch squealing noise. In fact it makes the noise around 900-3500 RPM and it only makes that noise after the engine is running at normal engine temp. While the engine is cold it will not make the noise. I first thought it was the water pump and had it changed out and the noise still persits. my mechanic stated that its the alternator: cause for my model year (97) they did not make a free spinnning pulley alternator which came much later. My mechanic said because the lights are on and radio is on it puts a load on the alternator during idleing speed or the problem is the two pulleys. I changed out the belt and tensioner, because it was makeing a sqeaky noise when I first turned on the vehicle and the engine was cold. this was at 101,000 miles now the car is 111,000 miles and this noise is annoying. the two pulleys or on back order and I will not recieve them until april so when I change them out I will let everyone know the outcome. Since my mechanic cant pinpoint the noise Im going to change out the pulleys first, thus its cheaper than the alternator. if anyone else has this same problem, please let me know so that I dont have to pay for something that does not need to be done or at least done now, thank you

Link to comment
Share on other sites

  • Moderators

Why not leave the engine idle for a couple of seconds without the belt, if the squeal is gone you know for sure it's related to the attributes driven by the belt, if not the engine/clutch assembly should be suspected. You should not have to be a mechanic to do that.

Link to comment
Share on other sites

Thank You, I will try that I prey to God that it has nothing to do with the engine. I changed my clutch and fly wheel assembly 2000 miles ago, so I think that is good. I will try that and let you know

Thank You, for the reply I tried that. The noise still remained I even gunned the engine a little and like before as soon as the engine is below 4000 RPM the noise comes back and is louder than the engine at idle speed. I did notice that takeing the oil fill cap off made my engine run harder in idle speed, in fact the idle speed flectuated from 800 - 1000 RPM as if someone was gunning my engine. the exhaust even came out faster. But as soon as I capped it the gunning and fast exhaust stopped. So its not the AOS.

Link to comment
Share on other sites

  • 10 months later...

Hello, I found out the true problem why my belt was squealing, my radiator fluid resvior was leaking right on the belt. As soon as i got a new resvior and changed the belt again, no more squeal so check to see if your resvior is leaking. my mechanic checked my pulleys and belt tensiors, plus he even checked the timing belt tensiors too. So if your radiator fluid is constantly low and you have to refill it every once and a while. It may be leaking, my leake was a very slow leak and it leaked directly on to the belt.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.