Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, ARE due Dec 6th, 2021. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Keyless (kessy) entry problem fixed ! after 5 dollars and 1 hour o


Recommended Posts

LONG STORY SHORT,,...My entry and drive system went bad one day., after almost a year of testing , replacing the battery, buying the test tool, almost brought a china piwis ,.... and bringing it to dealer and 800 dollars of dealer time., I had it fixed for 5 Dollars in parts. and one hr of soldering

at first my kessy do not communicate to the darmatic tool or PIWIS at all, the dealer went ahead try to replace it , with a superseeded module, HOWEVER they wasn't able to program it for unknown reason, there is no module out there that will take my car's pin and complete the marry process because they said all the module has been superceeded.

The dealer offer me to replace ALL the module in the car to an updated version for a cheapo $3000 dollars.! OF COURSE I refused,. ...,. I only lost my alarm horn , entry and drive function and its not worth $3000 dollars,.

I was investigating myself trying to see what causing the problem, I came in to the touareg forum and found out those guys there have a lot of the problems with their module too. ... I was like ,hum.,,. then go under my dash and found the kessy module that is EXACTLY the same as theirs including the part number (WHICH IS A VW part number stamped on a sticker btw)....

there is one guy there that took his module to a local electrician and found he has 2 fried mofset and 6 fried resistors.!!!

I was like, fxxx it, why don't I give it a try, at first I couldn't found the 0.22ohm resistors (its was HARD trust me I took almost 2 months looking for them)., so I went ahead replaced the two mofset........... 15 mins and a lot of smoke later....... MAN,,,... the module can communicate with my Durametic tool...! HOWEVER,, all the antennas are reporting short to ground ERROR!!! I tried to clear it but the code come back instantly.

then I went on to test the resistor value,... and found all six of the 0.22ohm resistors are SHORT (they are fusible resistor btw)....,,. sooooo I tried my best and finally able to locate those 0.22 ohm resistor ..,

fast forward 2 months later............ I received those resistors today.............. another 15 mins of smoke and sweat with my resoldering station... I plug the module back... run the scan tool clean the fault codes!!!!...................

moment of truth,, I plug my dummy key in to the key cyclinder with the real key in my pocket!!!!!!!!!!!!! turn and the CAR STARTS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I have successfully fixed a $3000 dollars repair (that don't guarantee will work) with 5 dollars worth of resistors !!!!!!

NOTE: IF your kessy don't communicate with the scan tool,. Its the TWO MOFSET that is Fried.

if you have all antennas short to ground or not responding its the 6 resistors!

  • Haha 1
  • Upvote 3
Link to comment
Share on other sites

Hey Timmy, any chance you can recall your source for those $5 parts? Please!! And maybe indicate on the pics which parts you replaced?

Tim in Ft Worth

I got the 0.22 OHM fusible resistor from mouser.com

I had them special ordered, but it seemed they purchased a LARGE amount after my special order,. and its now listing on their website now

the MOFSET

I got it from West Florida Electronic

Link to comment
Share on other sites

  • 7 months later...
  • 2 weeks later...

The mosfet is mfgd by International Rectifier which has been purchased by Vishay the mfg's p/n is IRFZ24N or IRFZ24NPBF they are approx $1.30 each from any of the online elect distributors, Avnet, Arrow, Digi-Key. The resistors are easily found at the same places.

Link to comment
Share on other sites

  • 2 years later...

I am about to do this repair as my Entry and Drive has stopped working and I really miss that feature!

Does anyone know the exact part numbers for the 0.22ohm fusible resistors? There is so many different kinds.

Thanks!

i posted a DIY in common fixes and repairs. there is a link there

FYI...these resistors sit across the drain of the transistors, if the resistors are blown, it's because one of the mosfets is bad.

Translation, replace everything at once (2 transistors and all 6 resistors.

Edited by clarksongli
Link to comment
Share on other sites

Thank you for the detailed DIY! Much appreciated clarksongli!

Will order the parts and try this ASAP, will report back for fun :)

I am about to do this repair as my Entry and Drive has stopped working and I really miss that feature!

Does anyone know the exact part numbers for the 0.22ohm fusible resistors? There is so many different kinds.

Thanks!

i posted a DIY in common fixes and repairs. there is a link there

FYI...these resistors sit across the drain of the transistors, if the resistors are blown, it's because one of the mosfets is bad.

Translation, replace everything at once (2 transistors and all 6 resistors.

Link to comment
Share on other sites

  • 2 weeks later...

Well I replaced the 2 Mosfets and the 6 resistors. I plugged the KESSY unit back in and it said "Ignition Faulty" then it started right up with the Porsche Entry & Drive dummy Key. I drove the car a bit and then tested the locking button on the drivers side and it worked again! The unlocking by touching the handle is also working on the front driver side door and the front passenger side door. My tailgate also works fine again.

The only thing I have a question for is that neither of my rear doors open while touching the handle, I am guessing this is not normal? Can anyone confirm?

Link to comment
Share on other sites

nope not normal. The MOSFETs control power to the antennas, so if one handle is working then it probably isn't the KESSY.

Chances are you have a bad handle/antenna but without a durametric it will be tough to tell for sure.

Congrats on getting the KESSY back up and running....I hope my PNs and DIY were semi helpful.

Link to comment
Share on other sites

Both the rear handles will lock the car by pushing the button but neither will open if the car is locked.

Yes thank you very much, especially by posting the part numbers was a huge help!

nope not normal. The MOSFETs control power to the antennas, so if one handle is working then it probably isn't the KESSY.

Chances are you have a bad handle/antenna but without a durametric it will be tough to tell for sure.

Congrats on getting the KESSY back up and running....I hope my PNs and DIY were semi helpful.

Link to comment
Share on other sites

I have a 04 Touareg and a 04 Cayenne TT that i just picked up (only 36k miles) for 21K. i forgot how easy the vehicle is with the Kessy working as the 10 year old Cayenne still works. My touareg however has not worked for 5 or 6 years :( this is great info i plan to try it out with my Treg to see if i can fix it. THANKS!!!!

Link to comment
Share on other sites

  • 1 month later...

I had my car at the dealer for a heating seat fuse blowing all the time.

They mentioned to me that the PST2 can still not communicate with the rear door antennas and that they are showing open circut.

Both my front door handles work for unlocking/locking, and my rear door handles will lock but not unlock.

nope not normal. The MOSFETs control power to the antennas, so if one handle is working then it probably isn't the KESSY.

Chances are you have a bad handle/antenna but without a durametric it will be tough to tell for sure.

Congrats on getting the KESSY back up and running....I hope my PNs and DIY were semi helpful.

Link to comment
Share on other sites

Ok so all my antennas are short again! The PIWIS is able to communicate to the KESSY module and I am able to start the car with the dummy key but none of the door handles or trunk sensors are working.

I guess I should try and re-solder 6 new resistors but I have a feeling that either one of the handles or one of the sensors is shorting the KESSY unit. Strange.

Link to comment
Share on other sites

Test the FETs....the resistors are there to blow when the FETs go bad. If the resistors are blowing then the FETs are leaking current.

To answer your question: From my understanding of the KESSY, all handle sensors are powered together (all or nothing on antennas). However, the buttons are NOT together. The fronts can work without the rears and vise versa.

I haven't had time to look into the handle buttons much, but it does seem like a common issue with the older Cayenne's.

If the handle sensors work then your FETs are OK, something else must power those handle buttons

Link to comment
Share on other sites

I will try and replace the FETs again.

My front door sensors and handle buttons were working for about 2 months.

My rear door sensors never worked, and the rear handle buttons always worked.

Rear hatch bumper sensors and DUMMY key also always worked.

Can't believe i've had the Cayenne for 3 years and I am still playing with this.

Edited by Brit6
Link to comment
Share on other sites

Wow this is getting stranger and stranger. The entry and drive stopped working again, i went into my MID (Multi Information Display) and went to comfort and door lock just to check the settings, everything looked ok. Once i exited the car, my handles worked again (I didnt change any settings). It worked on and off for the day, then stopped completly, i tried the same thing on the MID and the handles are working again.

What to try next?

Edited by Brit6
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.