Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
skymast

Help: Passenger Window Inoperable

Recommended Posts

My Passenger window doesnt work. Luckily, it is in the up position but i am trying to trouble shot the possible problems / Fix. Thx!

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

There is only two fuses related to the power window and they are D1 and B6 but if one of those was burnt you would not have any window operating. The first thing to do is eliminate the switch failure. Just transfer the left switch with the right one and see if the switch is at fault. Can you hear the motor movement inside the door??? If not you have to get to the six wires that are going into the door and trouble shoot from there to see if the motor is at fault..... Do the window go down a little bit when door handle is moved ???? Here's the wiring diagram for the power window system. There is only one plug and it is located just before entering the door (DP door X12).... You can disconnect that plug and put a volmeter there to see if you got power... Start with the grey/violet wire and a good ground while selecting the switch to up see if you got 12 volts....

post-29683-0-19487200-1301319999_thumb.j

post-29683-0-95634500-1301326798_thumb.j

Edited by jpflip

Share this post


Link to post
Share on other sites

thank you for the diagram. My switch is good, no fuse issues, and it does not go down at all. the one thing i did notice is that, when the window is up, if i press the up button, i can see a micro movement so it appears to be getting some power. Also, there is no grinding / noise.

Share this post


Link to post
Share on other sites

The only previous fault that we have seen here on Renntech related to window is the switch within the door handle and the window regulator. The problem you have seem to come from the motor but I am not confident with that one. If the motor or the regulator were jammed a fuse would be burned... Please keep us inform of your findings.

Share this post


Link to post
Share on other sites

My Passenger window doesnt work. Luckily, it is in the up position but i am trying to trouble shot the possible problems / Fix. Thx!

Very common for the window regulator to break... have to replace the whole mechanism.

Share this post


Link to post
Share on other sites

before i start ordering parts, is there a way to isolate if my problem is the regulator or the motor? when i hit the control button, nothing happens. its not the switch (i have switched them) and there is no grinding. thx!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.