Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

strange noise after turn on headkights


Recommended Posts

Hi everyone. I need help whit my 2000 S. When I turn on the headlights, most of times, I start wearing a tap tap tap noise in the rear engine and sometimes I get oil or battery warning lights, or both. I just shut off the car and in restart, turn de headlights on and 8 in 10 times all is ok. Sometimes I have to restart the car twice. Can someone help me whit this? Could be some error in electric system whit the headlights switch and the rear spoiler? I have no idea, the spoiler stays down.

Another problem is the engine idle. I have clean de MAF and change the air filter, but only works smooth whit the air conditioned on and from some level of ventilation. That’s strange too. Anyone can help?

Thank

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

You don't happen to have an aftermarket HID/Xenon light kit in there do you? Warning lights are common w/ some of the cheaper made kits.

Otherwise, could be issue w/ light switch (common failure), ignition switch (common failure) or alternator (at 10+ yrs old w/ ?? miles, not uncommon).

As for MAF, are you getting any check engine light or error codes? Usually people have erratic idle when AC is ON... so I guess you have a good problem w/ steady idle. Might try cleaning the throttle body too. Also, was AOS (Air Oil Separator) ever replaced?

:)

Link to post
Share on other sites

You don't happen to have an aftermarket HID/Xenon light kit in there do you? Warning lights are common w/ some of the cheaper made kits.

Otherwise, could be issue w/ light switch (common failure), ignition switch (common failure) or alternator (at 10+ yrs old w/ ?? miles, not uncommon).

As for MAF, are you getting any check engine light or error codes? Usually people have erratic idle when AC is ON... so I guess you have a good problem w/ steady idle. Might try cleaning the throttle body too. Also, was AOS (Air Oil Separator) ever replaced?

:)

Hi Cassiebox, thanks for your answer,

The car already have original xenon lights, so maybe de light switch or the alternator, because only get the noise when I turn on the light switch. I need to replace the tensioner pulley, but I don’t believe that's the problem.

About the idle, the car do not report any errors, not at all, a friend checks with a odbc connection, but I will clean de throttle body, because, now you mentioned, the idle gets more smooth after that friend check and clean some connections in the engine near the throttle body and I will check about the AOS, but I don’t think was ever replaced.

Link to post
Share on other sites
  • 1 month later...

I have the same thing (2001 S). A couple of times a season I'll start it up (no lights on)

-or- I'll come up to a stoplight and turn the lights on......I'll hear a loud thumping in the

rear and will have to turn the car off and restart it. It's something in the spoiler circuitry

because the next day I'll turn the car off and get out after a sub-40 mph ride and the rear

spoiler will be deployed. I retract the spoiler with the switch on the kick-panel and then

all is well for weeks/months. The spoiler seems to get out of synch with where it actually

is and is trying to retract when it already is - I think that is the thumping noise (Porsche

techs?). Then it deploys on subsequent start-ups before it is supposed to. Manually

positioning with the switch seems to fix it for a while.

That's my opinion on the (our) problem. I've posted this concern before - no responses.

Link to post
Share on other sites

Hi everyone

The problem with the noise, was the xenon. When I turned on the lights, sometimes, the spoiler goes up and that was the tapping noise.I change to a can-bus xenon kit and its all Ok now.

About the idle no news for now,I have to clean the throttle body first.

Thanks for all your contributions.

Edited by aabm
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.