Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Engine Stuttering and Fuel Filter Exchange...


Recommended Posts

Porsche recommends exchanging the fuel filter every 80'000km. Mine was last done at the 80'000km service, since then the car has done 55'000km. Some symptoms that I had, non disturbing but still sometimes annoying:

- engine stuttering after startup

- engine stuttering at 3100rpm in 6th gear on the highway

- engine sometime just went out, specially when reversing with warm engine

After the fuel filter change today and some long test driving all these issues seem to be gone.

Fuel filter change how-to in addition to the instructions found in the workshop manual (they didn't really help...). Fuel filter 996 110 253 52, purchased at FVD for CHF 42.

If you do not have the workshop manual, you can find the instructions here in this renntech post.

The first few steps according to manual are easy:

1) remove the air filter box

IMG_1358.jpg

2) disconnect mass cable, undo the fuel line with counter wrench, make sure there is a big towel underneath, there is a lot of fuel coming out

3) disconnect the plug connection

IMG_1359.jpg

4) now the difficult part: it says 'remove the fuel filter with holder', 'to do this bend the retaining clip upwards as shown where the arrow is'. The arrow points to the top of the fuel filter - where of course no clip can be found. Space is very tight so you cannot do a lot of searching with your hand. I used a borescope to look underneath but couldn't figure a way to work this thing. So I ended up with a wrench with extender, flexible part up front with a screw driver end and completely loosened the restraining strap and pulled the fuel filter out with a mole grips (the fuel line in the back is so strong I couldn't pull it out by hand). I then could see the following picture below the the easy to remove holder (the rectangular front piece). I have no clue how I should have removed it with my big hands....if you have kids, give them a try.

IMG_1360.jpg

5) The rest was easy, take the holder out, attach the new filter, put it back into place so that you hear a clipping sound and connect the fuel lines, mass cable and put the rest you have remove back into place.

6) The picture below shows the fuel I have removed from the old filter...all black and dirty, not good. So if you have symptoms like I had, try replacing the fuel filter earlier than maintenance schedule.

IMG_1361.jpg

Visit my blog for high resolution pictures: click here.

Edited by fedmax
Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

fedmax, looked over your blog. Great job.

Did you sort that clack when lifting the Accelerator with that front drive shaft?

Thanks! A little, it got reduced by changing the drive shaft, the flex disc was work out. But the clack is related to the sports clutch from Sachs that I fitted, it has no springs. I have a standard clutch ready for mounting and hope it will be gone then.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.