Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Cab top goes down, but struggles to go up


Recommended Posts

MY03 Carrera Cab (50,500 miles). The Cab top goes down ok, but struggles to go up. The dealer says I need a new hydraulic pump ($1200), but, this situation has been slowly getting worse which makes me think it could simply be that I need to add hydraulic fluid. The dealer disagrees and says they checked it. I read the DIY and it looks fairly easy to get to the pump, but how will I know if it is low on fluid or not? Does the reservoir need to be 100% full? Thanks in advance.

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Gonzo,

When you get the carpet out around where the top sits when open look at the translucent white plastic part at the bottom on the pump. On mine, it was translucent white completely and I couldn't see any level. If yours looks like this you need to fill it up. With hydraulic fluid inside it will be dark rather than translucent white.

I'm pretty useless at DIY and even I managed it, so I say go for it.

Link to post
Share on other sites

I can definitely see the fluid level in the plastic container. When I fill it to the top, the fluid level is about 1/4 inch from the top of the container. Like everyone says, this is a very easy procedure. Took me about 45 min the first time and now about 10 min start to finish.

Link to post
Share on other sites

Refilling the hydraulic system is not going to fix the problem all the way. It'll make it work again for a week or two. The fluid level is low because you have a leak somewhere, which will continue leaking under pressure. Most likely a seal in the cylinder is worn; this is a common problem amongst our cars after they reach a certain age.

I got my car a little over a year ago, and almost immediately I had the same problem. Same scenario, the reservoir was almost empty and the roof was having a hard time moving despite the sounds of motors whirring. I found a guy local to my area (Sarasota, FL) who rebuilds cylinders, and was able to get my car fixed very inexpensively. I use my roof extensively and these things have held up really well so far; there have been no leaks and no change in performance. Removing and reinstalling the cylinders is not a difficult DIY project, and you should be able to send him your old ones to get rebuilt. PM me for more info.

Link to post
Share on other sites

Refilling the hydraulic system is not going to fix the problem all the way. It'll make it work again for a week or two. The fluid level is low because you have a leak somewhere, which will continue leaking under pressure. Most likely a seal in the cylinder is worn; this is a common problem amongst our cars after they reach a certain age.

I got my car a little over a year ago, and almost immediately I had the same problem. Same scenario, the reservoir was almost empty and the roof was having a hard time moving despite the sounds of motors whirring. I found a guy local to my area (Sarasota, FL) who rebuilds cylinders, and was able to get my car fixed very inexpensively. I use my roof extensively and these things have held up really well so far; there have been no leaks and no change in performance. Removing and reinstalling the cylinders is not a difficult DIY project, and you should be able to send him your old ones to get rebuilt. PM me for more info.

I wondered the same thing, but I had absoutely no fluid leaks anywhere. It's been about a month and it still (knock on wood) working perfectly.

Link to post
Share on other sites
  • Moderators

It is still possible that the pump is leaking a bit, if the hydraulic fluid level drops after a while, then are you sure. The fluid does not disappear without a reason.

  • Upvote 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.