Jump to content

Server Lease Renewal/Software Licenses - Goal Reached!

A big Thank You to all those that donated to help us reach our 2019 goal (and pay the site operating costs)!

Just an FYI - if all members of this site had donated - then the cost per member would have been less than $0.06 each.

Thanks again to all of you that did contribute!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
working4it

Shifter will not up or down shift in M

Recommended Posts

Okay...so today I went to pull around a semi moved the shifter to M and went to "-" nothing tried moving it back to D and back to M still nothgin. Pushed the selector on the steering wheel everything worked fine. I tried multiple times on the ride home and nothing on the shifter but everything worked fine using the steering wheel controls. Hooked it up when I got home and no codes. I even took the key out let it sit and retried nothing from the shifter.... thoughts?

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

My 2006 TT does the same - manual gear selection stopped working. D is OK and Tiptronic is OK and as I rarely use manual shift I havent tried to fix it yet. One of those get a round tuit jobs

PKN

Share this post


Link to post
Share on other sites

Does the instrument display show the "M" symbol when the shifter is selected into the M gate?

Share this post


Link to post
Share on other sites

Not sure if the Cayenne is the same but on the Touareg there is a set of magnets in the shifter housing that can fall out of their housing and the manual shift mode will no longer operate. I have just glued the magnets back into their positions and everything worked again. I think the magnets energize a hall effects switch.

Share this post


Link to post
Share on other sites

Good questions...I will double check "M" today and will look at taking off the cover to see what I find...

Share this post


Link to post
Share on other sites

Since you are getting the M via the steering wheel switches, I would be looking into the shifter housing and checking out the sensor actuators / hall effect sensors to see if they are intact as wvicary also suggests.

  • Upvote 1

Share this post


Link to post
Share on other sites

I hope your fix is as easy as mine. I finally got around to dismantling the various layers of plastic top get to the shifter mechanism and a dime fell out during the process. There was also a plastic piece under the rear edge of the mechanism that was not located by its plastic lugs. I reassembled before checking for any more change and it is now fully operational again. I have no idea how the dime got all of the way in there.......

PKN

Share this post


Link to post
Share on other sites

It's funny you mentioned that....I did a preliminary look at I did find a dime. Unfortunately, it did solve my issue. I need to completely remove the plastic pieces and check the magnets and a switch.

Share this post


Link to post
Share on other sites

Yes it's fixed. Once I disassembled the shifter I found a magnet loose. The plastic holder was broken. I have no idea how it broke but some epoxy back in place all Better! I didn't think about taking pictures until I was putting everything back together, sorry

Share this post


Link to post
Share on other sites

I'm having similar problems. I was tipped off when I couldn't get my key out of the ignition. After I turned off my lights the key came out. I then noticed that with the lights off, I could see the "D" light still faintly on. I can't switch the shifter into manual mode, but the steering wheel controls work. The lights at the shifter are doing some wonky shorting out kind of thing. Before I tear it apart is this the same issue as stated above?

Share this post


Link to post
Share on other sites

Pulled out the plastics and magnets were intact. Turning the lights on shows that the D is always light up, regardless of position. Seems like a short somewhere..but where! Any ideas? I read about a plug on the transmission that could short out and all lights light up..Think its that? and I can get to it without a hoist and slide under the vehicle and check it out.

PLEASE HELP!

Share this post


Link to post
Share on other sites

Best to have the system checked for fault codes and post them here. It would solve years of guess work.

Share this post


Link to post
Share on other sites

Fuses checked, at local mechanic this morning to clean and inspect the electrical connections on the transmission.

What do the electromagnets 955.624.170.00 do? They are in the shifter mechanism..just an uneducated stab in the dark if they would cause such a prob. But I'm sure its a short as the lights in the selector are doing funky things:

1. There are no lights on to show what gear you are in, unless you turn the headlights on, at which time the gear is light up, as well as the D light (faint)

2. I can still operate the low range selectror

3. Cannot get the key out , says "put selector in park". If i turn on and off real quick, I can get it to release if I pull on the key as I do this.

4. The steering wheel lock is not engaged. When I put my key in, I get no "Clicking" of the interlock mechanisms, and, on getting the key out the lock out mechanisms do not engage

5. Tiptronic works on the steering wheel, but not on the shifter. Shifting it over to M, lights up the M light quickly then goes out, and D stays lit up. The Manual shifting does not work at all

Share this post


Link to post
Share on other sites

i dont know how to solve your problem but on a normal car what you describe could be achieved by removing fuse for gear selector.

Share this post


Link to post
Share on other sites

You really need to have the system checked for fault codes.

Share this post


Link to post
Share on other sites

Corroded wires in harness due to sunroof drains clogged. oh joy.

I have exactly the same symptoms as yours; can you tell or show where is and how to fix the corroded wire? PLEASE HELP!!

Thank you one million!

Edited by paulwu

Share this post


Link to post
Share on other sites

I am new to the forum, but this start of this post is exactly like my issue on 2004 cayenne s. Silver M shifters work fine on steering wheel, but gear shifter does nothing in M mode. I have found and was able to take the center console off with no issues, but how to I open the black box to get the magnets to check them out? any photos or diagrams available? Thanks in advance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.