Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
ubu

idle problem with new plenum ipd

Recommended Posts

Hi all,

Just mount new plenum ipd 74 mm and K&N air filter on 3,4l boxster S MY 2007

but idle jumped at 1400 r/mn instead of 700 r/mn before, even after 50 miles test

Any idea or solution ?

thanks per advance

Edited by ubu

Share this post


Link to post
Share on other sites

Thanks Loren

I had a mail back from Greg at IPD

Hard reboot is the solution and now idle is back to 650 r/mn

- shut out battery at negative for 30 mn

- engage key just before start for 1 mn

- push the accelerator pedal once

-close key out

- put key

-start

- push PSM button

thats ' it

Edited by ubu

Share this post


Link to post
Share on other sites

Just saw this and was wondering how the IPD is working? Do you have improved low RPM HP and torque? Have you done post install dyno runs?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.