Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

1. Saturday: Each time I start to accelerant over ~4000rmps I lose all acceleration. Check errors and get P1120 and P1121. Clear errors… as soon as I go over ~4000 rpms I can’t accelerant. Like I hit a rev-limiter.

2. Sunday: Switch out O2 sensors after cats running great.

3. I lost all Throttle response today. Restart and unable to accelerate after ~4000 rpms. Error code P1122 and P1120/P1121. I am thinking it’s the Throttle Valve Assembly 997-605-115-01-M14.

2002 Carrera C2 CAB.

IMG_1003.JPG

Edited by Chris996
Link to comment
Share on other sites

  • Admin

P1120 Throttle Valve – Signal Implausible

P1121

Throttle position sensor 1 - signal implausible

Throttle position sensor 1 - below limit

Throttle position sensor 1 - above limit

P1122

431 Throttle position sensor 2 - signal implausible

431 Throttle position sensor 2 - below limit

431 Throttle position sensor 2 - above limit

Possible fault cause

- Open circuit or short circuit in the wiring

- Throttle position sensor faulty

- DME control module faulty

Make sure the throttle valve connectors are secure and clean. Check for cuts or other damage.

Reset the codes and see if they come back.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.