Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
rbelkin

power windows and cruise control

Recommended Posts

My 2007 Cayman S passenger window for the past month -

It's as if the window can't decide if the door is open or shut, so it goes up and down for that last 1/2 inch travel to seat and unseat in rubber door seal anywhere from 1-15 cycles, usually 1-3. This seems to happen unpredictably, often with the least electrical provocation, including opening or shutting DRIVER door, pulling passenger door handle, using remote to lock or unlock, putting key in ignition, or starting car. Seems worse when car is cold(?).

Tried resetting memory, then took an expensive flyer and replaced door lock containing the notorious microswitch. Seemed to work perfectly for 3-4 days, but now back to square one although not quite as bad.

Also my main cruise control switch failed - a failure so apparently rare there was no part in USA and had to order from Germany.

before I go flat broke or crazy?

Any ideas out there? Thanks for reading.

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.