Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

    You can remove these ads by becoming a Contributing Member.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Bardia Manafi
      Hi all, just purchased a 1961 notchback 1600s, I have never drove a Porsche until the day I purchased this car, got the bug now and i love Porsches more than ever now, the car is in very good shape, but i want to change all the fluids, grease all the parts, and do all the maintenance there is, the oil was so dark when I checked the level and it was all the way to max line of the stick, i would appreciate if you guys can tell me where to buy all the maintenance parts, and where can I buy the shop manual, and what are the things I should do, there is a small leak on the floor from engine very small, but a palm size of oil from transmission on the ground,  thanks guys cheers😁

    • By Nicky_Noodle
      I have a 2004 Cayenne S. I just got it recently, interior lights have never worked. I checked the fuse and it was blown. It calls for a 20 amp fuse but the blown one in it was a 25 amp. I had the key in the ignition if I remember correctly and put the new 20 amp fuse in and everything came on. Side note, I noticed a weird glitch with the light above the rear passenger side door and the switch on the main map reading light. The interior lights had gone off and I turned the back on and the backlight above to passenger side door was very dim. I slid the switch on the overhead console for the main map light and the rear light came back to full strength. I found that odd. Everything then worked fine. I took the key out. Next time I put the key in, immediately heard the fuse blow. Any ideas on where to start?
    • By Astarael
      Hello there, this is my first post here and I’m writing because of problem with my boxster.
      Today in the morning I’ve started my 2002 boxster and noticed strange sounds from the engine/ rear side of the car
      It’s a metallic, grinding sound like a loose piece of metal or something like that
      Sound disappears when you press gas and comes back once you loose the pedal, I don’t know if it changes while engine is warm
       
      Also, check engine light shown up yesterday, when I connected my BT OBD2 there was no error code.
      I came with that to workshop also, and they said it’s a catalyst efficiency error.
       
      I’ve had that error code a while ago, I’ve replaced mass air flow meter and check engine light disappeared. 
      I think it might be a problem with maf again because I bought not the cheaper, not the original one, but why are there these strange sounds? I’m worried about this. Could it be catalyst this time? Or again should I replace maf? This time I’ll buy original one.
       
       
       
      here are two Videos I made
       
       
       
       
       
      Also I’m sorry if you can’t understand something, my english is not perfect.
      Thank you for all replies, I hope we will solve that problem together
    • By Liam Strauss
      Me and my dad have recently bought a 2001 Porsche Boxster that has not been run in 2 years, as a "fairly easy" project to start with. So where to begin we did all the basics for a car that hasn't run in 2 years, we replaced the spark plugs and tubes, so then when we tried to throw some gas in it wont let us, we have checked the E6 fuse as was suggested on other forums, we slowly threw in some gas at a time, about 5 gallons in total. When we tried to start it it didn't, so when we tried to troubleshoot we found that it has no spark. So does anyone have any idea or suggestions on how to fix any or all of these things?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.