Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Clutch pedal different feel each time pressed


Recommended Posts

Hi all

It's been some time since I had a strange issue, but one came up this week: After driving off I noticed something like vibrations when I pressed the clutch pedal. The clutch worked fine, opened and closed but a little later same drive the feel or let's say the amound of power necessary to press the clutch varied each time I pressed it. Sometimes with vibrations, sometimes without. I drove the car a few times since, the clutch works but the feeling is a different one almost every time. It feels normal from time to time for a few pressures but then again goes harder and I'm 90% sure the point where the clutch engages also varies a bit.

Remote diagnoisis anyone? Hope it's not a part failure...had enough of those ;-)

Thanks

Ronny

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • 2 weeks later...

Those accumulators are notorius for failure for some reason... The clutch is also notorius for needing to be bled a few times too. So if it starts feeling goofy again after a few days bleed it again. Seems to take a few days for all of the small bubbles to work their way out.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.