Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Airbag warning light does NOT come on anymore


Recommended Posts

Hi ,

I experience a strange issue with my airbag warning light:

It does not come on anymore when you turn the ignition key before starting the car, normally it should come on as test like all other lights do.

I heard of at least 2 cases where the MY 2005 cockpit modules are supposed to have a software bug - whenever you later on code an extra function into the cockpit (like e.g. cruise control in my case was retrofitted), the airbag warning light does not work anymore.

Most shops are not aware of that issue, but at least one seems to be.

There seems to be a fix known to the factory installing a later or different firmware to the cockpit ECU so that the airbag light comes back as normal.

- Has anybody come across that issue?

- Any known specific fixes? Could your Porsche dealer help you?

- Most important - I did not find a TSB on it... :-((( - any help and hint appreciated..

My dealer seemed not to be informed, I hope they will manage to get a fix, with factory help...

It should effect only early 987 (and 997) models, 2005, maybe 2006.

Pls only comment on fixes - I know most folks would not care as the cockpit would throw eror messages anyway.., but in Germany it's required to be street legal.

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

..like I expected - the dealer did not help and "of course" is not aware of any software bugs with the 2005 clusters. Only charged 150 bucks to diagnose a defect cluster.. well. great!

Just baught as used one on ebay for 250 bucks instead of the 2000 the dealer wants for a new one, keep my fingers crossed it works. If not I can return it..

Link to post
Share on other sites
  • Admin

..like I expected - the dealer did not help and "of course" is not aware of any software bugs with the 2005 clusters. Only charged 150 bucks to diagnose a defect cluster.. well. great!

Just baught as used one on ebay for 250 bucks instead of the 2000 the dealer wants for a new one, keep my fingers crossed it works. If not I can return it..

You do realize the used cluster will still need to be programmed to your car?

Link to post
Share on other sites

Yes of course we'll need to program the other cluster to my car with a PIWIS, we'll do that in case the airbag light works on that one.

To test the airbag light should be possible w/o reprogramming the cluster. I believe...

Plus, I'll have to find a specialized expert to set the mileage to the correct value of the original cluster if everything else would work, not sure what the cluster I bought will show.

Link to post
Share on other sites

Ok, done and fixed . The used cluster does the job quite nicely. No re-coding or programming required, it just works as it should, seems to be the correct coding for my car already. Only I had to change the language from Spanish to German. :-)))

Of course I will need to get the miles corrected to the actual values by a pro, easy fix for few bucks.

Nevertheless, I was close to get my old cluster getting fixed by a pro repair shop. would have cost me he same...

The owner knew of the bug some early clusters have when getting re-coded. Basically, there seems to be a memory area in one of the Eproms which memorizes the airbag light to be on or off when key gets into ignition, re-coding the older clusters can lead to an invalid memory value in that specific eprom. The shop owner previously worked for the amnufacturer, VDO and told me the architecture of the clusters itself never changed. Since he knows the memory area which needs to be corrected he could fix it in re-coding the eprom affected in the specific byte area. as the used cluster did zhe job for me, I did not lethim fix it.

Thus, coding with what it seems older versionsof Piwis can screw early clusters as some more sources revealed.of course the official dealer still refuses to discuss... Butit seems that some memory area gets changed its values by a bug.

Now, we have not figured out yet if a Piwis could solve and set the values back to correct settings but will test itwith my old cluster in the coming weeks. One way might be to flash a later MY cluster firmware .

Lucky me, as the new cluster just works and has all functions it should have, no need to code it and risk screwing it as well.

Only thing apart from correcting the mileage gauge will be to read out OBD codes with durametric tomorrow to see if it creates any error messsages.

  • Upvote 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.