Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Hi all

Finally decided to do the clutch. Raised the back of the car and removed plastic covers - all good so far. Then tried to remove the sway bar to fit an engine support brace. The bolts holding the sway bar bushes to the subframe all eventually sheared off - even with WD40, tapping with a hammer and heat. It's really frustrating to hit this kind of problem on step 1 of the process!

So now I think the only solution is to remove the subframes and get them to a machine shop to have the bolts drilled out.

The manual I have doesn't cover subframe removal. Is there anything to watch out for or can I just undo all the bolts?

Any thoughts or guidance much appreciated.

Thanks

Andy

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

The sub frame is held in place by four bolts. Not a big thing to take it off, but they say not to move the car around until it is pUt back in place.

You can find lots of these subframes on eBay for about $100. They are all the same for C2, C4, etc from '99-'05 I believe

Share this post


Link to post
Share on other sites

Actually there is one on eBay right now for $55, free shipping. Probably less than having them drilled out.

Share this post


Link to post
Share on other sites

Thanks for your inout. Different terms for different parts I think though. The sway bar bolts to the carrier for all the suspension links, I called this a subframe but I'm not sure that's the correct name. I think the part you are thinking of is what I would call a cross member. it's a shame because the cross member would have been much easier to sort. Anyway, in the end I drilled out the bolts withe the subframes in situ. Two of the bolts went very well and the original thread was preserved but on the other two the hole I drilled went off centre. I plan to put nuts on the back of all four bolts anyway as the threads are bound to be weaker now.

Apart from some tight bell housing bolts everything else went quite well with the removal. Hopefully put it back next weekend.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By 2seatcollector
      I'm trying to remove the heater control on my 2002 986, so I can replace the malfunctioning LCD.  Since the failure of these older LCDs (the radio has the same issues) is such a common problem, I thought there might be a tutorial here, to review, before I go prying away at the dash.  But I haven't been able to find one by doing a simple "Heater Control Removal" search.  Can anyone enlighten me with a link or the smoothest removal procedure?  Spring is almost here, so I need to fix this for driving!  
       
      Also looking for the easiest way to replace the partly defective display on the Becker Radio LCD.  The 2002 has the security radio with the plug-in display, so at least this is easy to remove.  Wondering if anyone has had a successful repair done on their Becker radio display, for less than an arm and a leg?
       
      Thanks!
    • By cburke996
      Putting in an order for some front suspension parts today, and I just want to make sure I have the correct sway bar bushings. I believe it is these, but since GT2 is in parenthises I'm not sure if they actually mean it is for a turbo or not. Can anyone tell for sure?
      http://www.pelicanparts.com/cgi-bin/smart/more_info.cgi?pn=996-343-792-16-M100&catalog_description=&Front%2520Sway%2520Bar%2520Bushing%252C%2520Stock%2520Rubber%2520%2528%2532%2520per%2520car%252C%2520sold%2520individually%2529%252C%2520%2539%2539%2536%2520GT%2533%2520%2528%2531%2539%2539%2539%252D%2530%2535%2529%252C%2520each%2520
      And for my front suspension overhaul, I'm attacking the following:
      Main control arms
      Control arm links
      sway bar bushing
      Recently did tie rods and sway bar end links.
      Should I add anything else to the list while I'm in there?
      Thanks,
      Connor
    • By Car Cro
      Hi everyone
      Well took my car out a few times this spring, and one day when pulling into my parking lot at work I hear a bang!
      Was not sure what it was but when I left work I was backing up and heard some scraping.
      I look underneath and my rear sway bar snapped between the bushing and the wheel on passenger side
      I have never personally seen a sway bar snap, but when I had it taken off, it had been broken halfway for a while.
      I bought the car couple years ago, and it is stored during the winter.
      I decided to go with Eibach front and rear kit, since the car is a 2001, decided to give it an upgrade.
      Has anyone done this upgrade, and what are your thoughts
      I have to wait 10 days to get the parts as no one stocks them, but look forward to driving it again,
    • By carreracup03
      Can anyone tell me how to remove the headlight switch on my 2005 CTT. I read you push in and turn counter clockwise, and it pops out. That does not seem to work. Any thoughts.
    • By Saibot
      Hi, i apologise for being a lurker and not really ever posting since i joined; but i have a serious issue right now :^(
      ive been DIYing most stuff for my car
      - pioneer nav
      - footwell lighting
      - seatbelt replacement
      - o2 sensor replacement
      etc etc.
      but this has me absolutely stumped.
      a few weeks ago the interior trim / lining of the sun roof came off while the sun roof was open. it basically got stuck above the headliner in the car; so after i closed the sunroof, i wasnt able to ever open it fully again. i tried to tackle this problem today and one problem led to another and this whole sunroof thing has me so frustrated.
      Basically where it stands now is; ive removed the entire ceiling of the car - center consol, headliner, sunroof, sunroof interior trim, motor, rails.. EVERYTHING,
      the reason for this was because after i unscrewed the sunroof pannel and removed it, the sunroof rails were not doing anything when i pressed buttons. i though there was something stuck in the tracks at first, but couldnt find anything. then i took out the motor to see wht was up and realized that the close button doesnt work but the vent button and the sunroof forward button do. they only turn the gears a few rotations before stopping. obviously because my roof is in the most extended positon (open) the motor only clicks and doesnt do anything when i press buttons; so i removed the motor to find that it can only rotate in one direction.
      what do i do??? i think its the **** programed circuit (the one with the NEC chip on it) thats got the problem. Any way to reset it; or to let the circuit know that the sunroof is already in the vent position and it needs to stop trying to make it vent more?
      p.s i broke the mechanism that lets me manually crank the sunroof lol. so thats not an option.
      ahhhhhhhhhhhhh!!!! any help is appreciated, or even a service manual that tells me how the hell i re-build the sunroof.
      p.p.s my possible diagnostics:
      something stuck in tracks
      the computer that tells the sunroof what to do is wonky
      the close button is broken
      motor for some reason only turns one way
      pleaase help with solutions, or a service manual to show me what to do :(
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.