Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
X50

Rear spoiler

Recommended Posts

Hello every one,

I have a 05 996 turbos.

just wanted to know why my rear spoiler light malfuctioned is on. when I test drive the car three times. it looks like the wing is fuctioning properly. when i reached 75miles it popped up,when i slow down it goes down. i tried it 3 times, and check the rear for its function and everythings all right. but light is still on, i wonder if it is the micro switches that are going bad? or is it something to do with the speedometer isue? anybody has any idea? I remove the system and check for leacks,NO leacks on any rams or the unit. Thank you.ALI

Edited by X50

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

As Loren says there are quite a few posts regarding spoiler. Perhaps you should just clear the code and see if it comes back.

Share this post


Link to post
Share on other sites

By disconnecting the battrey would it clear the code OR I would need a scanner?because when you start the car there is no spoiler light ,only when you reach 75mils light comes on you can see spoiler comes up all the way and when you stop is goes down all the way.when you turn off the car and turn in on again no warning light seen, until you drive and reach 75mils again.

Share this post


Link to post
Share on other sites

Switch pack at fault on the right side. Look if it is not out of position. I had to tape mine to keep it firmly positioned.... If it didn't work operate the spoiler manually , once completely up force the right side up to see if it reach completely the deployed position.

Share this post


Link to post
Share on other sites

I think i fixed it yet not sure i test drive and wing operate correctly ,and light did not come on, what i did, remove both micro switches and so slightly open their contact with a ortho plier,i was thinking may be when i press them in their places their contact were press, light if off i am afraid to place the cap back because it may mobe the wires and switches.left the cap out for now, i may have to replace the switches. does any one know where you can get the best price for them.

Share this post


Link to post
Share on other sites

I was never able to found only the switch but if you do let us know!

Share this post


Link to post
Share on other sites

One thing that i learn from this spoiler isue is if your system is not leaking oil ,the failure alert sign is due to micro switches, i play with both switches by adjusting their gap, Increasing or decreasing the gaps in the switches has direct effect in the warning light and spoiler fuction.i did this several time until system start to operate corectly and failure light is gone. I order the switches thru a comany call ECStunig and i will replace both if my switches fail.I wanted to share this with you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.